aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Kwiki
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /www/p5-Kwiki
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'www/p5-Kwiki')
-rw-r--r--www/p5-Kwiki/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/www/p5-Kwiki/Makefile b/www/p5-Kwiki/Makefile
index fbd40c7227cf..04602cb2b7b9 100644
--- a/www/p5-Kwiki/Makefile
+++ b/www/p5-Kwiki/Makefile
@@ -22,6 +22,6 @@ PLIST_SUB= KWIKIDIR=${KWIKIDIR}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${KWIKIDIR}
- cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${KWIKIDIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/${KWIKIDIR})
.include <bsd.port.mk>