aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-ConnCache-MaxKeepAliveRequests
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2009-02-04 14:04:17 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2009-02-04 14:04:17 +0000
commitad119ee53c3241d98c752f3b8282c5b49e3a228e (patch)
tree033e9bd39980919d9fcdcd01d90dc191fc21b684 /www/p5-LWP-ConnCache-MaxKeepAliveRequests
parenta7d87b554817f36279cb8b3e4cd5ec09919f18dc (diff)
downloadports-ad119ee53c3241d98c752f3b8282c5b49e3a228e.tar.gz
ports-ad119ee53c3241d98c752f3b8282c5b49e3a228e.zip
LWP::UserAgent is the default module for issuing HTTP requests from
Perl. It has a keep_alive setting which by default allows unlimited requests to the same server. Some servers will disconnect you after a limited number of requests (in Apache 2 this is achieved with the MaxKeepAliveRequests directive). This module allows you to limit the maximum number of keep alive requests to a server. WWW: http://search.cpan.org/dist/LWP-UserAgent-Determined/
Notes
Notes: svn path=/head/; revision=227616
Diffstat (limited to 'www/p5-LWP-ConnCache-MaxKeepAliveRequests')
-rw-r--r--www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile25
-rw-r--r--www/p5-LWP-ConnCache-MaxKeepAliveRequests/distinfo3
-rw-r--r--www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-descr8
-rw-r--r--www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-plist7
4 files changed, 43 insertions, 0 deletions
diff --git a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile
new file mode 100644
index 000000000000..7421e3463961
--- /dev/null
+++ b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-LWP-ConnCache-MaxKeepAliveRequests
+# Date created: 2009-02-04
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-ConnCache-MaxKeepAliveRequests
+PORTVERSION= 0.32
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= A connection cache that enforces a max keep alive limit
+
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::ConnCache::MaxKeepAliveRequests.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/distinfo b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/distinfo
new file mode 100644
index 000000000000..9c406d705c0f
--- /dev/null
+++ b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/distinfo
@@ -0,0 +1,3 @@
+MD5 (LWP-ConnCache-MaxKeepAliveRequests-0.32.tar.gz) = ee1843e7ff418660f5a5f782b65c6f28
+SHA256 (LWP-ConnCache-MaxKeepAliveRequests-0.32.tar.gz) = 1145419805b176d92e8a4097ff2b60525fca194745dab774750f9ef1cac04ed7
+SIZE (LWP-ConnCache-MaxKeepAliveRequests-0.32.tar.gz) = 2081
diff --git a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-descr b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-descr
new file mode 100644
index 000000000000..5829b7d6e778
--- /dev/null
+++ b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-descr
@@ -0,0 +1,8 @@
+LWP::UserAgent is the default module for issuing HTTP requests from
+Perl. It has a keep_alive setting which by default allows unlimited
+requests to the same server. Some servers will disconnect you after
+a limited number of requests (in Apache 2 this is achieved with the
+MaxKeepAliveRequests directive). This module allows you to limit
+the maximum number of keep alive requests to a server.
+
+WWW: http://search.cpan.org/dist/LWP-UserAgent-Determined/
diff --git a/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-plist b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-plist
new file mode 100644
index 000000000000..ce407181f549
--- /dev/null
+++ b/www/p5-LWP-ConnCache-MaxKeepAliveRequests/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/LWP/ConnCache/MaxKeepAliveRequests.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/ConnCache/MaxKeepAliveRequests/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/ConnCache/MaxKeepAliveRequests
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP/ConnCache
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/LWP
+@dirrm lib/perl5/site_perl/5.8.9/LWP/ConnCache
+@dirrmtry lib/perl5/site_perl/5.8.9/LWP