aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Protocol-http10/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-14 08:49:43 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-14 08:49:43 +0000
commit816fd54fa7b67e106d0c2283ba6efa9670af541b (patch)
tree349623a78976d69cd0c82054d2c2e2753e3460af /www/p5-LWP-Protocol-http10/Makefile
parent305e675cfe6af1f9e1659543afe74bc600616156 (diff)
downloadports-816fd54fa7b67e106d0c2283ba6efa9670af541b.tar.gz
ports-816fd54fa7b67e106d0c2283ba6efa9670af541b.zip
- Add p5-LWP-Protocol-http10 6.02
The LWP::Protocol::http10 module provide support for using HTTP/1.0 protocol with LWP. To use it you need to call LWP::Protocol::implementor() to override the standard handler for http URLs. This module used to be bundled with the libwww-perl, but it was unbundled in v6.02 as part of the general cleanup for the 6-series. LWP::Protocol::http10 is deprecated. WWW: http://search.cpan.org/dist/LWP-Protocol-http10/
Notes
Notes: svn path=/head/; revision=277674
Diffstat (limited to 'www/p5-LWP-Protocol-http10/Makefile')
-rw-r--r--www/p5-LWP-Protocol-http10/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/p5-LWP-Protocol-http10/Makefile b/www/p5-LWP-Protocol-http10/Makefile
new file mode 100644
index 000000000000..821d6d622445
--- /dev/null
+++ b/www/p5-LWP-Protocol-http10/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-LWP-Protocol-http10
+# Date created: 2011-07-11
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Protocol-http10
+PORTVERSION= 6.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Legacy HTTP/1.0 support for LWP
+
+RUN_DEPENDS= p5-HTTP-Message>=6:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-libwww>=6:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Protocol::http10.3
+
+.include <bsd.port.mk>