aboutsummaryrefslogtreecommitdiff
path: root/www/p5-LWP-Protocol-https/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-11 06:03:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-11 06:03:31 +0000
commit626f63a0e4b0ad40f1f24fb777e109e96922c6c3 (patch)
tree052d37327923ee7b753a2ca51413b8dd925ad464 /www/p5-LWP-Protocol-https/Makefile
parent99765ada6a01c8ddf0a51326e03675d1cba3eb7e (diff)
downloadports-626f63a0e4b0ad40f1f24fb777e109e96922c6c3.tar.gz
ports-626f63a0e4b0ad40f1f24fb777e109e96922c6c3.zip
- Add p5-LWP-Protocol-https 6.02
The LWP::Protocol::https module provide support for using https schemed URLs with LWP. This module is a plug-in to the LWP protocol handling, so you don't use it directly. Once the module is installed LWP is able to access sites using HTTP over SSL/TLS. If hostname verification is requested by LWP::UserAgent's ssl_opts, and neither SSL_ca_file nor SSL_ca_path is set, then SSL_ca_file is implied to be the one provided by Mozilla::CA. If the Mozilla::CA module isn't available SSL requests will fail. Either install this module, set up an alternative SSL_ca_file or disable hostname verification. This module used to be bundled with the libwww-perl, but it was unbundled in v6.02 in order to be able to declare its dependencies properly for the CPAN tool-chain. Applications that need https support can just declare their dependency on LWP::Protocol::https and will no longer need to know what underlying modules to install. WWW: http://search.cpan.org/dist/LWP-Protocol-https/
Notes
Notes: svn path=/head/; revision=277509
Diffstat (limited to 'www/p5-LWP-Protocol-https/Makefile')
-rw-r--r--www/p5-LWP-Protocol-https/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/www/p5-LWP-Protocol-https/Makefile b/www/p5-LWP-Protocol-https/Makefile
new file mode 100644
index 000000000000..39d951eed7ad
--- /dev/null
+++ b/www/p5-LWP-Protocol-https/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-LWP-Protocol-https
+# Date created: 2011-06-05
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= LWP-Protocol-https
+PORTVERSION= 6.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Provide https support for LWP::UserAgent
+
+# We remove p5-libwww here to avoid cyclic dependency
+RUN_DEPENDS= p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Mozilla-CA>=20110101:${PORTSDIR}/www/p5-Mozilla-CA \
+ p5-Net-HTTP>=6:${PORTSDIR}/net/p5-Net-HTTP
+
+PERL_CONFIGURE= yes
+
+MAN3= LWP::Protocol::https.3
+
+.include <bsd.port.mk>