aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Maypole
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2004-04-08 18:27:19 +0000
committerErwin Lansing <erwin@FreeBSD.org>2004-04-08 18:27:19 +0000
commit0ea1b848c57790e7f6de9b09b62714222ed4c264 (patch)
tree00273263f8a221211ede18c624d567ead681bedb /www/p5-Maypole
parentbe877f4b086a4f1f3bdb3e58c73996f1f8620448 (diff)
downloadports-0ea1b848c57790e7f6de9b09b62714222ed4c264.tar.gz
ports-0ea1b848c57790e7f6de9b09b62714222ed4c264.zip
Add p5-Maypole 1.3, mVC web application framework.
Maypole is an MVC-based web application framework, built around Class::DBI and Template Toolkit. WWW: http://search.cpan.org/~simon/Maypole/ PR: ports/65328 Submitted by: Lars Thegler <lars@thegler.dk>
Notes
Notes: svn path=/head/; revision=106508
Diffstat (limited to 'www/p5-Maypole')
-rw-r--r--www/p5-Maypole/Makefile44
-rw-r--r--www/p5-Maypole/distinfo2
-rw-r--r--www/p5-Maypole/files/patch-Makefile.PL22
-rw-r--r--www/p5-Maypole/pkg-descr4
-rw-r--r--www/p5-Maypole/pkg-plist11
5 files changed, 83 insertions, 0 deletions
diff --git a/www/p5-Maypole/Makefile b/www/p5-Maypole/Makefile
new file mode 100644
index 000000000000..c9dfa039be82
--- /dev/null
+++ b/www/p5-Maypole/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: p5-Maypole
+# Date created: Apr 2 2004
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+
+PORTNAME= Maypole
+PORTVERSION= 1.3
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SI/SIMON/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@thegler.dk
+COMMENT= MVC web application framework
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/DBI/Loader.pm:${PORTSDIR}/databases/p5-Class-DBI-Loader \
+ ${SITE_PERL}/Class/DBI/AbstractSearch.pm:${PORTSDIR}/databases/p5-Class-DBI-AbstractSearch \
+ ${SITE_PERL}/Class/DBI/Pager.pm:${PORTSDIR}/databases/p5-Class-DBI-Pager \
+ ${SITE_PERL}/Class/DBI/Plugin/RetrieveAll.pm:${PORTSDIR}/databases/p5-Class-DBI-Plugin-RetrieveAll \
+ ${SITE_PERL}/Class/DBI/AsForm.pm:${PORTSDIR}/databases/p5-Class-DBI-AsForm \
+ ${SITE_PERL}/Class/DBI/FromCGI.pm:${PORTSDIR}/databases/p5-Class-DBI-FromCGI \
+ ${SITE_PERL}/Class/DBI/Loader/Relationship.pm:${PORTSDIR}/databases/p5-Class-DBI-Loader-Relationship \
+ ${SITE_PERL}/CGI/Untaint.pm:${PORTSDIR}/www/p5-CGI-Untaint \
+ ${SITE_PERL}/UNIVERSAL/moniker.pm:${PORTSDIR}/devel/p5-UNIVERSAL-moniker \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-exports \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+
+PERL_CONFIGURE= yes
+
+MAN3= Apache::MVC.3 \
+ Maypole.3 \
+ Maypole::Model::Base.3 \
+ Maypole::Model::CDBI.3 \
+ Maypole::Workflow.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Perl 5.6 or newer required. Install lang/perl5 or lang/perl5.8 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-Maypole/distinfo b/www/p5-Maypole/distinfo
new file mode 100644
index 000000000000..4866681d14b8
--- /dev/null
+++ b/www/p5-Maypole/distinfo
@@ -0,0 +1,2 @@
+MD5 (Maypole-1.3.tar.gz) = 541fb9dd1718c8e92c6edec9b1d9bf64
+SIZE (Maypole-1.3.tar.gz) = 22504
diff --git a/www/p5-Maypole/files/patch-Makefile.PL b/www/p5-Maypole/files/patch-Makefile.PL
new file mode 100644
index 000000000000..4bdad7ea3015
--- /dev/null
+++ b/www/p5-Maypole/files/patch-Makefile.PL
@@ -0,0 +1,22 @@
+--- Makefile.PL.orig Thu Mar 25 13:33:42 2004
++++ Makefile.PL Thu Apr 8 18:13:57 2004
+@@ -20,14 +20,17 @@
+ Template => 0,
+ }, # e.g., Module::Name => 1.1
+ ($] >= 5.005 ? ## Add these new keywords supported since 5.005
+- (ABSTRACT_FROM => 'lib/Apache/MVC.pm', # retrieve abstract from module
++ (ABSTRACT_FROM => 'lib/Maypole.pm', # retrieve abstract from module
+ AUTHOR => 'Simon Cozens <simon@simon-cozens.org>') : ()),
+ );
+
+ if (!-e "t/beerdb.db") {
+ print "Making SQLite DB\n";
+ eval { require DBD::SQLite };
+- die "No, wait, we don't have SQLite installed. Never mind\n" if $@;
++ if ($@) {
++ warn "No, wait, we don't have SQLite installed. Never mind\n";
++ exit;
++ }
+ require DBI;
+ my $dbh = DBI->connect("dbi:SQLite:dbname=t/beerdb.db");
+
diff --git a/www/p5-Maypole/pkg-descr b/www/p5-Maypole/pkg-descr
new file mode 100644
index 000000000000..c319da03a1e5
--- /dev/null
+++ b/www/p5-Maypole/pkg-descr
@@ -0,0 +1,4 @@
+Maypole is an MVC-based web application framework, built around
+Class::DBI and Template Toolkit.
+
+WWW: http://search.cpan.org/~simon/Maypole/
diff --git a/www/p5-Maypole/pkg-plist b/www/p5-Maypole/pkg-plist
new file mode 100644
index 000000000000..90af9b0f2093
--- /dev/null
+++ b/www/p5-Maypole/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Apache/MVC.pm
+%%SITE_PERL%%/Maypole.pm
+%%SITE_PERL%%/Maypole/Workflow.pod
+%%SITE_PERL%%/Maypole/Model/CDBI.pm
+%%SITE_PERL%%/Maypole/Model/Base.pm
+%%SITE_PERL%%/Maypole/View/TT.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Maypole
+@unexec rmdir %D/%%SITE_PERL%%/Maypole/Model 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Maypole/View 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Maypole 2>/dev/null || true