aboutsummaryrefslogtreecommitdiff
path: root/www/p5-McBain/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-01-05 23:00:05 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-01-05 23:00:05 +0000
commit53c049027fac37d75d812c7e65fa7efb21e9c09d (patch)
tree8cbeec033498b07404c8629ab61d7103d252a852 /www/p5-McBain/Makefile
parentbdbc873f9bae63869b61af09ad7417efd9541509 (diff)
downloadports-53c049027fac37d75d812c7e65fa7efb21e9c09d.tar.gz
ports-53c049027fac37d75d812c7e65fa7efb21e9c09d.zip
Add the McBain web framework system, including p5-Brannigan (a text validation and parsing system),
p5-McBain (an API-driven self-documenting web framework), and p5-McBain-WithPSGI, a Plack/PSGI adapter for McBain. See: https://metacpan.org/pod/Brannigan https://metacpan.org/pod/McBain https://metacpan.org/pod/McBain-WithPSGI
Notes
Notes: svn path=/head/; revision=376368
Diffstat (limited to 'www/p5-McBain/Makefile')
-rw-r--r--www/p5-McBain/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/p5-McBain/Makefile b/www/p5-McBain/Makefile
new file mode 100644
index 000000000000..e1a31c5bb683
--- /dev/null
+++ b/www/p5-McBain/Makefile
@@ -0,0 +1,24 @@
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= McBain
+PORTVERSION= 2.001000
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:IDOPEREL
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Lightweight auto-validating, self-documenting web framework
+
+LICENSE= GPLv1 PERLART10
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-Brannigan>=0:${PORTSDIR}/devel/p5-Brannigan \
+ p5-Getopt-Compact>=0:${PORTSDIR}/devel/p5-Getopt-Compact \
+ p5-Try-Tiny>=0:${PORTSDIR}/lang/p5-Try-Tiny
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>