aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-Amazon-AWIS/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /www/p5-Net-Amazon-AWIS/Makefile
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'www/p5-Net-Amazon-AWIS/Makefile')
-rw-r--r--www/p5-Net-Amazon-AWIS/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/www/p5-Net-Amazon-AWIS/Makefile b/www/p5-Net-Amazon-AWIS/Makefile
index 5bec739dc798..a84eca45a14a 100644
--- a/www/p5-Net-Amazon-AWIS/Makefile
+++ b/www/p5-Net-Amazon-AWIS/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Net-Amazon-AWIS
PORTVERSION= 0.36
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,14 +14,15 @@ COMMENT= Use the Amazon Alexa Web Information Service
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
- p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-IO-Prompt>=0:${PORTSDIR}/devel/p5-IO-Prompt \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
USES= perl5
USE_PERL5= configure