aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Net-Trac/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:16:23 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 18:16:23 +0000
commitd09631e65badbf437dee001e67f561261f255bef (patch)
treeeb08439bb94a6b074a317582c4f8c43eaf30e7c2 /www/p5-Net-Trac/Makefile
parent64331fb434fdd94682192ca1b081691ebe501e9a (diff)
downloadports-d09631e65badbf437dee001e67f561261f255bef.tar.gz
ports-d09631e65badbf437dee001e67f561261f255bef.zip
Net::Trac is simple client library for a remote Trac instance. Because
Trac doesn't provide a web services API, this module currently "fakes" an RPC interface around Trac's webforms and the feeds it exports. Because of this, it's somewhat more brittle than a true RPC client would be. WWW: http://search.cpan.org/dist/Net-Trac/ PR: ports/134386 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=233616
Diffstat (limited to 'www/p5-Net-Trac/Makefile')
-rw-r--r--www/p5-Net-Trac/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-Net-Trac/Makefile b/www/p5-Net-Trac/Makefile
new file mode 100644
index 000000000000..bb554c9cf574
--- /dev/null
+++ b/www/p5-Net-Trac/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Net-Trac
+# Date created: 2009-05-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Trac
+PORTVERSION= 0.13
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interact with a remote Trac instance
+
+RUN_DEPENDS= p5-Any-Moose>0:${PORTSDIR}/devel/p5-Any-Moose \
+ p5-DateTime>0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Lingua-EN-Inflect>0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect \
+ p5-Params-Validate>0:${PORTSDIR}/devel/p5-Params-Validate \
+ p5-Text-CSV>0:${PORTSDIR}/textproc/p5-Text-CSV \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-WWW-Mechanize>=1.52:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Trac.3 \
+ Net::Trac::Connection.3 \
+ Net::Trac::Mechanize.3 \
+ Net::Trac::Ticket.3 \
+ Net::Trac::TicketAttachment.3 \
+ Net::Trac::TicketHistory.3 \
+ Net::Trac::TicketHistoryEntry.3 \
+ Net::Trac::TicketPropChange.3 \
+ Net::Trac::TicketSearch.3
+
+.include <bsd.port.mk>