aboutsummaryrefslogtreecommitdiff
path: root/www/p5-ParallelUA
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1998-09-08 17:25:20 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1998-09-08 17:25:20 +0000
commitb30ee8def0f942f3d769409b0c0779d754c8a1fd (patch)
tree715dfda8a0140c4fdb48233d0dbb5cd8b03220e4 /www/p5-ParallelUA
parenteaf4ab3271a629fe51d3f54877fe43b2c48b263d (diff)
downloadports-b30ee8def0f942f3d769409b0c0779d754c8a1fd.tar.gz
ports-b30ee8def0f942f3d769409b0c0779d754c8a1fd.zip
Parallel LWP UserAgent
Notes
Notes: svn path=/head/; revision=13053
Diffstat (limited to 'www/p5-ParallelUA')
-rw-r--r--www/p5-ParallelUA/Makefile35
-rw-r--r--www/p5-ParallelUA/distinfo1
-rw-r--r--www/p5-ParallelUA/pkg-comment1
-rw-r--r--www/p5-ParallelUA/pkg-descr8
-rw-r--r--www/p5-ParallelUA/pkg-plist16
5 files changed, 61 insertions, 0 deletions
diff --git a/www/p5-ParallelUA/Makefile b/www/p5-ParallelUA/Makefile
new file mode 100644
index 000000000000..31fb47746174
--- /dev/null
+++ b/www/p5-ParallelUA/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Parallel-UA
+# http://www.cs.washington.edu/homes/marclang/ParallelUA/
+# Version required: 2.36
+# Date created: Sep 8 1998
+# Whom: ache@freebsd.org
+#
+# $Id: Makefile,v 1.20 1998/08/19 13:09:15 vanilla Exp $
+#
+
+DISTNAME= ParallelUserAgent-2.36
+PKGNAME= p5-ParallelUA-2.36
+CATEGORIES= www perl5 devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= LWP
+
+MAINTAINER= ache@FreeBSD.ORG
+
+BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= YES
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= LWP::Parallel.3 \
+ LWP::Parallel::Protocol.3 \
+ LWP::Parallel::RobotUA.3 \
+ Bundle::ParallelUA.3 \
+ LWP::Parallel::UserAgent.3 \
+ LWP::ParallelUA.3 \
+ LWP::RobotPUA.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/www/p5-ParallelUA/distinfo b/www/p5-ParallelUA/distinfo
new file mode 100644
index 000000000000..1cf1d92f90e0
--- /dev/null
+++ b/www/p5-ParallelUA/distinfo
@@ -0,0 +1 @@
+MD5 (ParallelUserAgent-2.36.tar.gz) = 255056599108111e77d1086db14b5a22
diff --git a/www/p5-ParallelUA/pkg-comment b/www/p5-ParallelUA/pkg-comment
new file mode 100644
index 000000000000..c0c68c36046f
--- /dev/null
+++ b/www/p5-ParallelUA/pkg-comment
@@ -0,0 +1 @@
+perl5 Parallel LWP User Agent for WWW access.
diff --git a/www/p5-ParallelUA/pkg-descr b/www/p5-ParallelUA/pkg-descr
new file mode 100644
index 000000000000..0b71751a1c7c
--- /dev/null
+++ b/www/p5-ParallelUA/pkg-descr
@@ -0,0 +1,8 @@
+ParallelUserAgent allows you to connect to multiple sites _in parallel_!
+You can register a number of requests, then call the 'wait' method and see
+how the requests come in as each server responds.
+
+ParallelUserAgent is basically an extension of the current UserAgent and
+RobotUA modules that come with libwww5. It installs into the ::Parallel
+subtree under the standard LWP directory that ships with libwww5.
+
diff --git a/www/p5-ParallelUA/pkg-plist b/www/p5-ParallelUA/pkg-plist
new file mode 100644
index 000000000000..7b3857e1a941
--- /dev/null
+++ b/www/p5-ParallelUA/pkg-plist
@@ -0,0 +1,16 @@
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/Protocol/http.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/Protocol/ftp.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/Protocol.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/RobotUA.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/UserAgent.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/ParallelUA.pm
+lib/perl5/site_perl/%%PERL_VER%%/LWP/RobotPUA.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bundle/ParallelUA.pm
+lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/LWP/Parallel/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel/Protocol
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Parallel
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Bundle
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/LWP/Parallel
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/i386-freebsd/auto/LWP