aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RPC-ExtDirect/Makefile
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2013-02-23 18:58:57 +0000
committerTom Judge <tj@FreeBSD.org>2013-02-23 18:58:57 +0000
commit248f7120044e7f33a0b6c80a95377d16215c7b6c (patch)
tree23029cb1a8eb4ed378bf49d809e557c2d7d486e8 /www/p5-RPC-ExtDirect/Makefile
parent678eff9c21376f148cb541f9e5a9070cd9016690 (diff)
downloadports-248f7120044e7f33a0b6c80a95377d16215c7b6c.tar.gz
ports-248f7120044e7f33a0b6c80a95377d16215c7b6c.zip
RPC::ExtDirect is a Perl implementation for Ext.Direct remoting protocol
used in Ext JS JavaScript framework by Sencha Inc. WWW: http://search.cpan.org/dist/RPC-ExtDirect/
Notes
Notes: svn path=/head/; revision=312846
Diffstat (limited to 'www/p5-RPC-ExtDirect/Makefile')
-rw-r--r--www/p5-RPC-ExtDirect/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/www/p5-RPC-ExtDirect/Makefile b/www/p5-RPC-ExtDirect/Makefile
new file mode 100644
index 000000000000..ccdddfe12410
--- /dev/null
+++ b/www/p5-RPC-ExtDirect/Makefile
@@ -0,0 +1,36 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= RPC-ExtDirect
+PORTVERSION= 2.10
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Perl extension for implimenting the Ext.Direct remoting protocol
+
+BUILD_DEPENDS= p5-Attribute-Handlers>=0.93:${PORTSDIR}/devel/p5-Attribute-Handlers \
+ p5-JSON>=2.53:${PORTSDIR}/converters/p5-JSON
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Pod>=1.46:${PORTSDIR}/devel/p5-Test-Pod
+
+PERL_CONFIGURE= yes
+
+MAN3= RPC::ExtDirect.3 \
+ RPC::ExtDirect::API.3 \
+ RPC::ExtDirect::Config.3 \
+ RPC::ExtDirect::Demo::PollProvider.3 \
+ RPC::ExtDirect::Demo::Profile.3 \
+ RPC::ExtDirect::Demo::TestAction.3 \
+ RPC::ExtDirect::Deserialize.3 \
+ RPC::ExtDirect::Event.3 \
+ RPC::ExtDirect::EventProvider.3 \
+ RPC::ExtDirect::Exception.3 \
+ RPC::ExtDirect::Hook.3 \
+ RPC::ExtDirect::NoEvents.3 \
+ RPC::ExtDirect::Request.3 \
+ RPC::ExtDirect::Router.3 \
+ RPC::ExtDirect::Serialize.3
+
+.include <bsd.port.mk>