aboutsummaryrefslogtreecommitdiff
path: root/www/p5-RT-Authen-ExternalAuth
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-01-25 03:51:23 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-01-25 03:51:23 +0000
commit9ac0428f4ad8be1876e3dc13ce35eed3655df519 (patch)
tree9bae1226ed3d0a1ac13f904d2ef81768458fb273 /www/p5-RT-Authen-ExternalAuth
parentd9f621e741a6d45dfef9d94c0195eb5ef6e3b764 (diff)
downloadports-9ac0428f4ad8be1876e3dc13ce35eed3655df519.tar.gz
ports-9ac0428f4ad8be1876e3dc13ce35eed3655df519.zip
RT::Authen::ExternalAuth RT Authentication using External Sources
A complete package for adding external authentication mechanisms to RT. It currently supports LDAP via Net::LDAP and External Database authentication for any database with an installed DBI driver. It also allows for authenticating cookie information against an external database through the use of the RT-Authen-CookieAuth extension. WWW: http://search.cpan.org/perldoc?RT::Authen::ExternalAuth PR: ports/129783 Submitted by: Matthew Seaman <m.seaman at infracaninophile.co.uk>
Notes
Notes: svn path=/head/; revision=226823
Diffstat (limited to 'www/p5-RT-Authen-ExternalAuth')
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile56
-rw-r--r--www/p5-RT-Authen-ExternalAuth/distinfo3
-rw-r--r--www/p5-RT-Authen-ExternalAuth/pkg-descr11
-rw-r--r--www/p5-RT-Authen-ExternalAuth/pkg-plist.rt3617
-rw-r--r--www/p5-RT-Authen-ExternalAuth/pkg-plist.rt3822
5 files changed, 109 insertions, 0 deletions
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
new file mode 100644
index 000000000000..02904c01faf7
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -0,0 +1,56 @@
+# New ports collection Makefile for: RT-Authen-ExternalAuth
+# Date created: 19 December 2008
+# Whom: Matthew Seaman <m.seaman@infracaninophile.co.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RT-Authen-ExternalAuth
+PORTVERSION= 0.05
+CATEGORIES= www net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= m.seaman@infracaninophile.co.uk
+COMMENT= RT extension to authenticate users against an external source
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
+
+PERL_CONFIGURE= yes
+
+MAN3= RT::Authen::ExternalAuth.3 RT::User_Vendor.3
+
+PLIST_SUB+= RTHOME=${RTHOME}
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_RT36)
+
+RTHOME?= rt3
+RT_PM_DIR= ${LOCALBASE}/${RTHOME}/lib
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt36
+PLIST= ${PKGDIR}/pkg-plist.rt36
+MAN3PREFIX= ${PREFIX}/${RTHOME}/local
+
+.else
+
+RTHOME?= share/rt38
+RT_PM_DIR= ${SITE_PERL}
+BUILD_DEPENDS+= ${RT_PM_DIR}/RT.pm:${PORTSDIR}/www/rt38
+PLIST= ${PKGDIR}/pkg-plist.rt38
+MAN3PREFIX= ${PREFIX}
+
+.endif
+
+# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
+# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
+# rather undesirably.
+do-configure:
+ @cd ${CONFIGURE_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
+ ${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-RT-Authen-ExternalAuth/distinfo b/www/p5-RT-Authen-ExternalAuth/distinfo
new file mode 100644
index 000000000000..db9aea08b9f6
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/distinfo
@@ -0,0 +1,3 @@
+MD5 (RT-Authen-ExternalAuth-0.05.tar.gz) = 87049f6adb6ff4c8f6cac9a266ae2cb8
+SHA256 (RT-Authen-ExternalAuth-0.05.tar.gz) = e4ef01558d874b438c4818c5de1a373b93b8c2d4abffe9b87f0b88807a93c47e
+SIZE (RT-Authen-ExternalAuth-0.05.tar.gz) = 34653
diff --git a/www/p5-RT-Authen-ExternalAuth/pkg-descr b/www/p5-RT-Authen-ExternalAuth/pkg-descr
new file mode 100644
index 000000000000..fee255ffdd31
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/pkg-descr
@@ -0,0 +1,11 @@
+RT::Authen::ExternalAuth RT Authentication using External Sources
+
+A complete package for adding external authentication mechanisms to
+RT. It currently supports LDAP via Net::LDAP and External Database
+authentication for any database with an installed DBI driver.
+
+It also allows for authenticating cookie information against an
+external database through the use of the RT-Authen-CookieAuth
+extension.
+
+WWW: http://search.cpan.org/perldoc?RT::Authen::ExternalAuth
diff --git a/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt36 b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt36
new file mode 100644
index 000000000000..5a253db2aaa1
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt36
@@ -0,0 +1,17 @@
+%%RTHOME%%/local/etc/Authen-ExternalAuth/RT_SiteConfig.pm
+%%RTHOME%%/local/lib/RT/Authen/ExternalAuth.pm
+%%RTHOME%%/local/lib/RT/User_Vendor.pm
+%%RTHOME%%/local/man/auto/RT/Authen/ExternalAuth/.packlist
+%%RTHOME%%/share/html/Callbacks/ExternalAuth/autohandler/Auth
+@dirrm %%RTHOME%%/share/html/Callbacks/ExternalAuth/autohandler
+@dirrm %%RTHOME%%/share/html/Callbacks/ExternalAuth
+@dirrmtry %%RTHOME%%/share/html/Callbacks
+@dirrmtry %%RTHOME%%/local/man/man3
+@dirrm %%RTHOME%%/local/man/auto/RT/Authen/ExternalAuth
+@dirrmtry %%RTHOME%%/local/man/auto/RT/Authen
+@dirrmtry %%RTHOME%%/local/man/auto/RT
+@dirrmtry %%RTHOME%%/local/man/auto
+@dirrmtry %%RTHOME%%/local/man
+@dirrm %%RTHOME%%/local/lib/RT/Authen
+@dirrmtry %%RTHOME%%/local/lib/RT
+@dirrm %%RTHOME%%/local/etc/Authen-ExternalAuth
diff --git a/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38 b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38
new file mode 100644
index 000000000000..b09d6d086abd
--- /dev/null
+++ b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38
@@ -0,0 +1,22 @@
+lib/RT/Authen/ExternalAuth.pm
+lib/RT/User_Vendor.pm
+man/auto/RT/Authen/ExternalAuth/.packlist
+%%RTHOME%%/plugins/RT-Authen-ExternalAuth/etc/RT_SiteConfig.pm
+%%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler/Auth
+%%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen/ExternalAuth.pm
+%%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/User_Vendor.pm
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT/Authen
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib/RT
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/lib
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth/autohandler
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks/ExternalAuth
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/html/Callbacks
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/html
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth/etc
+@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth
+@dirrm man/auto/RT/Authen/ExternalAuth
+@dirrmtry man/auto/RT/Authen
+@dirrm man/auto/RT
+@dirrmtry man/auto
+@dirrmtry lib/RT/Authen
+@dirrmtry lib/RT