aboutsummaryrefslogtreecommitdiff
path: root/www/p5-URI-Fetch
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 11:19:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 11:19:32 +0000
commit0cb47f77537c2b13f5acb82c1ad559fbfe26a829 (patch)
treeca9945973b3815f11f68140f3be1ab0a2cb34abb /www/p5-URI-Fetch
parent604cf10be2fdf875d9d65a0ecd7cc4e9ec54a2cf (diff)
downloadports-0cb47f77537c2b13f5acb82c1ad559fbfe26a829.tar.gz
ports-0cb47f77537c2b13f5acb82c1ad559fbfe26a829.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297871
Diffstat (limited to 'www/p5-URI-Fetch')
-rw-r--r--www/p5-URI-Fetch/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
index 583d9bf873ae..cacf84acee63 100644
--- a/www/p5-URI-Fetch/Makefile
+++ b/www/p5-URI-Fetch/Makefile
@@ -20,8 +20,11 @@ RUN_DEPENDS= p5-Class-ErrorHandler>=0:${PORTSDIR}/devel/p5-Class-ErrorHandler \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
BUILD_DEPENDS= ${RUN_DEPENDS}
-OPTIONS= ZLIB "GZIP Support" on \
- CACHE "Caching Support" off
+OPTIONS_DEFINE= ZLIB CACHE
+OPTIONS_DEFAULT= ZLIB
+
+ZLIB_DESC= GZIP Support
+CACHE_DESC= Caching Support
PERL_CONFIGURE= yes
@@ -30,13 +33,13 @@ MAN3= URI::Fetch.3 \
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_ZLIB)
+.if ${PORT_OPTIONS:MZLIB}
. if ${PERL_LEVEL} < 500903
RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
. endif
.endif
-.if defined(WITH_CACHE)
+.if ${PORT_OPTIONS:MCACHE}
RUN_DEPENDS+= p5-Cache>=0:${PORTSDIR}/devel/p5-Cache
.endif