aboutsummaryrefslogtreecommitdiff
path: root/www/p5-URI-Fetch
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-07-30 19:44:28 +0000
committerLars Thegler <lth@FreeBSD.org>2005-07-30 19:44:28 +0000
commit5eb010164638d72ce29adedd49b8299cf2b7e53d (patch)
tree6ae9d0af427d32ee6515f3256886fe5ef3d24794 /www/p5-URI-Fetch
parent8c91f8349c0f883c5c8d0caf67b72d2f291405b6 (diff)
downloadports-5eb010164638d72ce29adedd49b8299cf2b7e53d.tar.gz
ports-5eb010164638d72ce29adedd49b8299cf2b7e53d.zip
Add p5-URI-Fetch 0.03, smart URI fetching/caching.
Notes
Notes: svn path=/head/; revision=140488
Diffstat (limited to 'www/p5-URI-Fetch')
-rw-r--r--www/p5-URI-Fetch/Makefile36
-rw-r--r--www/p5-URI-Fetch/distinfo2
-rw-r--r--www/p5-URI-Fetch/pkg-descr5
-rw-r--r--www/p5-URI-Fetch/pkg-plist4
4 files changed, 47 insertions, 0 deletions
diff --git a/www/p5-URI-Fetch/Makefile b/www/p5-URI-Fetch/Makefile
new file mode 100644
index 000000000000..5b868be54b46
--- /dev/null
+++ b/www/p5-URI-Fetch/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: www/p5-URI-Fetch
+# Date created: 30 July 2005
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Fetch
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Smart URI fetching/caching
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= URI::Fetch.3 \
+ URI::Fetch::Response.3
+
+post-patch:
+ ${PERL} -pi -e '$$_ = "" if m|auto_install|' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or later. Please install lang/perl5 or lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-URI-Fetch/distinfo b/www/p5-URI-Fetch/distinfo
new file mode 100644
index 000000000000..ad390ffa5efc
--- /dev/null
+++ b/www/p5-URI-Fetch/distinfo
@@ -0,0 +1,2 @@
+MD5 (URI-Fetch-0.03.tar.gz) = dea50360e9e39ffe361f131e5ad2f3d1
+SIZE (URI-Fetch-0.03.tar.gz) = 19315
diff --git a/www/p5-URI-Fetch/pkg-descr b/www/p5-URI-Fetch/pkg-descr
new file mode 100644
index 000000000000..195b4b5eb21b
--- /dev/null
+++ b/www/p5-URI-Fetch/pkg-descr
@@ -0,0 +1,5 @@
+URI::Fetch is a smart client for fetching HTTP pages, notably
+syndication feeds (RSS, Atom, and others), in an intelligent,
+bandwidth- and time-saving way.
+
+WWW: http://search.cpan.org/dist/URI-Fetch
diff --git a/www/p5-URI-Fetch/pkg-plist b/www/p5-URI-Fetch/pkg-plist
new file mode 100644
index 000000000000..42f801222858
--- /dev/null
+++ b/www/p5-URI-Fetch/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/URI/Fetch.pm
+%%SITE_PERL%%/URI/Fetch/Response.pm
+@dirrm %%SITE_PERL%%/URI/Fetch
+@unexec rmdir %D/%%SITE_PERL%%/URI 2>/dev/null || true