aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Mechanize-FormFiller
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-07-07 12:51:13 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-07-07 12:51:13 +0000
commit6fc31271beb408b200e396f7928d705b0ff4184e (patch)
treeaa2ad7aeb538f417dffb2b3a88201cc67264693e /www/p5-WWW-Mechanize-FormFiller
parente0d4f8826958c506e7ba877707abab0ab4cd45ef (diff)
downloadports-6fc31271beb408b200e396f7928d705b0ff4184e.tar.gz
ports-6fc31271beb408b200e396f7928d705b0ff4184e.zip
Add www/p5-WWW-Mechanize-FormFiller, Perl framework to automate HTML
forms.
Notes
Notes: svn path=/head/; revision=113134
Diffstat (limited to 'www/p5-WWW-Mechanize-FormFiller')
-rw-r--r--www/p5-WWW-Mechanize-FormFiller/Makefile63
-rw-r--r--www/p5-WWW-Mechanize-FormFiller/distinfo2
-rw-r--r--www/p5-WWW-Mechanize-FormFiller/pkg-descr10
-rw-r--r--www/p5-WWW-Mechanize-FormFiller/pkg-plist20
4 files changed, 95 insertions, 0 deletions
diff --git a/www/p5-WWW-Mechanize-FormFiller/Makefile b/www/p5-WWW-Mechanize-FormFiller/Makefile
new file mode 100644
index 000000000000..d24ef58d0e17
--- /dev/null
+++ b/www/p5-WWW-Mechanize-FormFiller/Makefile
@@ -0,0 +1,63 @@
+# New Ports Collection Makefile for: p5-WWW-Mechanize-FormFiller
+# Date created: 2004-07-07
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= WWW-Mechanize-FormFiller
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl framework to automate HTML forms
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Random.pm:${PORTSDIR}/devel/p5-Data-Random \
+ ${SITE_PERL}/HTML/Form.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Mechanize::FormFiller.3 \
+ WWW::Mechanize::FormFiller::Value.3 \
+ WWW::Mechanize::FormFiller::Value::Callback.3 \
+ WWW::Mechanize::FormFiller::Value::Default.3 \
+ WWW::Mechanize::FormFiller::Value::Fixed.3 \
+ WWW::Mechanize::FormFiller::Value::Interactive.3 \
+ WWW::Mechanize::FormFiller::Value::Keep.3 \
+ WWW::Mechanize::FormFiller::Value::Random.3 \
+ WWW::Mechanize::FormFiller::Value::Random::Chars.3 \
+ WWW::Mechanize::FormFiller::Value::Random::Date.3 \
+ WWW::Mechanize::FormFiller::Value::Random::Word.3
+
+FIX_USE_WARN= lib/WWW/Mechanize/FormFiller.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Interactive.pm \
+ t/embedded-WWW-Mechanize-FormFiller-Value-Interactive.t \
+ t/embedded-WWW-Mechanize-FormFiller.t
+
+FIX_USE_BASE= lib/WWW/Mechanize/FormFiller/Value/Callback.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Default.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Fixed.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Interactive.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Keep.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Random/Chars.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Random/Date.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Random/Word.pm \
+ lib/WWW/Mechanize/FormFiller/Value/Random.pm
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+.for _patch in ${FIX_USE_WARN}
+ ${MV} ${WRKSRC}/${_patch} ${WRKSRC}/${_patch}.orig
+ ${ECHO_CMD} 'BEGIN{if($$] < 5.006 && !$$::INC{"warnings.pm"}){ eval q|package warnings;sub import{$$^W=1}sub unimport{$$^W=0;1}$$::INC{"warnings.pm"}=1|}}' >${WRKSRC}/${_patch}
+ ${CAT} ${WRKSRC}/${_patch}.orig >>${WRKSRC}/${_patch}
+ ${RM} ${WRKSRC}/${_patch}.orig
+.endfor
+.for _patch in ${FIX_USE_BASE}
+ ${PERL} -pi -e 's/(use base .([\w:]+).;)/use $$2;$$1/' ${WRKSRC}/${_patch}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/www/p5-WWW-Mechanize-FormFiller/distinfo b/www/p5-WWW-Mechanize-FormFiller/distinfo
new file mode 100644
index 000000000000..37d5c6124826
--- /dev/null
+++ b/www/p5-WWW-Mechanize-FormFiller/distinfo
@@ -0,0 +1,2 @@
+MD5 (WWW-Mechanize-FormFiller-0.05.tar.gz) = ffd7f488439c202d45ac6081b268eb38
+SIZE (WWW-Mechanize-FormFiller-0.05.tar.gz) = 17179
diff --git a/www/p5-WWW-Mechanize-FormFiller/pkg-descr b/www/p5-WWW-Mechanize-FormFiller/pkg-descr
new file mode 100644
index 000000000000..92f64785ebf6
--- /dev/null
+++ b/www/p5-WWW-Mechanize-FormFiller/pkg-descr
@@ -0,0 +1,10 @@
+The module is intended as a simple way to fill out HTML forms from a set
+of predetermined values. You set up the form filler with value elements,
+retrieve the HTML form, and let the form filler loose on that form.
+
+There are value classes provided for many tasks - fixed values, values
+to be queried interactively from the user, values taken randomly from a
+list of values and values specified through a callback to some Perl
+code.
+
+WWW: http://search.cpan.org/search?dist=WWW-Mechanize-FormFiller
diff --git a/www/p5-WWW-Mechanize-FormFiller/pkg-plist b/www/p5-WWW-Mechanize-FormFiller/pkg-plist
new file mode 100644
index 000000000000..c1a81f1c098f
--- /dev/null
+++ b/www/p5-WWW-Mechanize-FormFiller/pkg-plist
@@ -0,0 +1,20 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/FormFiller/.packlist
+%%SITE_PERL%%/WWW/Mechanize/FormFiller.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Keep.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Random.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Fixed.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Default.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Interactive.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Callback.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Random/Date.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Random/Chars.pm
+%%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Random/Word.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize/FormFiller
+@dirrm %%SITE_PERL%%/WWW/Mechanize/FormFiller/Value/Random
+@dirrm %%SITE_PERL%%/WWW/Mechanize/FormFiller/Value
+@dirrm %%SITE_PERL%%/WWW/Mechanize/FormFiller
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Mechanize 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW/Mechanize 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/WWW 2>/dev/null || true