aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Shorten-Bitly
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-10 22:39:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-10 22:39:25 +0000
commitbebbccbd4b2030dc726c2e0871ee1d2438f81de7 (patch)
treefa0710953c57c704eda32dddd530f7aabc968d2f /www/p5-WWW-Shorten-Bitly
parent253f266f9f1a62f573509834b05a68ce26107b12 (diff)
downloadports-bebbccbd4b2030dc726c2e0871ee1d2438f81de7.tar.gz
ports-bebbccbd4b2030dc726c2e0871ee1d2438f81de7.zip
A Perl API to Bit.ly, one of URL shortening sites.
WWW: http://search.cpan.org/dist/WWW-Shorten-Bitly/ PR: ports/134329 Submitted by: Masafumi NAKANE <max at FreeBSD.org>
Notes
Notes: svn path=/head/; revision=233655
Diffstat (limited to 'www/p5-WWW-Shorten-Bitly')
-rw-r--r--www/p5-WWW-Shorten-Bitly/Makefile26
-rw-r--r--www/p5-WWW-Shorten-Bitly/distinfo3
-rw-r--r--www/p5-WWW-Shorten-Bitly/pkg-descr3
-rw-r--r--www/p5-WWW-Shorten-Bitly/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/www/p5-WWW-Shorten-Bitly/Makefile b/www/p5-WWW-Shorten-Bitly/Makefile
new file mode 100644
index 000000000000..64162fae935c
--- /dev/null
+++ b/www/p5-WWW-Shorten-Bitly/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-WWW-Shorten-Bitly
+# Date created: May 7, 2009
+# Whom: Masafumi NAKANE <max@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Shorten-Bitly
+PORTVERSION= 1.06
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= max@FreeBSD.org
+COMMENT= Abstract interface to URL shortening sites
+
+BUILD_DEPENDS= p5-JSON-Any>=1.18:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-WWW-Shorten>=1.9:${PORTSDIR}/www/p5-WWW-Shorten \
+ p5-XML-Simple>=2.18:${PORTSDIR}/textproc/p5-XML-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Shorten::Bitly.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Shorten-Bitly/distinfo b/www/p5-WWW-Shorten-Bitly/distinfo
new file mode 100644
index 000000000000..bd869eedb866
--- /dev/null
+++ b/www/p5-WWW-Shorten-Bitly/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Shorten-Bitly-1.06.tar.gz) = b5c39fd1f14483eb7856a89de9a8e5f1
+SHA256 (WWW-Shorten-Bitly-1.06.tar.gz) = 19f371decfe5c7b83df27c304bfedb65d5759257515d299d49bf83bea8dd7219
+SIZE (WWW-Shorten-Bitly-1.06.tar.gz) = 5990
diff --git a/www/p5-WWW-Shorten-Bitly/pkg-descr b/www/p5-WWW-Shorten-Bitly/pkg-descr
new file mode 100644
index 000000000000..e28c8b00eb21
--- /dev/null
+++ b/www/p5-WWW-Shorten-Bitly/pkg-descr
@@ -0,0 +1,3 @@
+A Perl API to Bit.ly, one of URL shortening sites.
+
+WWW: http://search.cpan.org/dist/WWW-Shorten-Bitly/
diff --git a/www/p5-WWW-Shorten-Bitly/pkg-plist b/www/p5-WWW-Shorten-Bitly/pkg-plist
new file mode 100644
index 000000000000..cda1c75ddf21
--- /dev/null
+++ b/www/p5-WWW-Shorten-Bitly/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/WWW/Shorten/Bitly.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Bitly/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Bitly
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/WWW/Shorten