aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-Shorten-Googl
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-09-10 01:42:22 +0000
committerSteve Wills <swills@FreeBSD.org>2011-09-10 01:42:22 +0000
commit0f27a63339f1953b9eade79421a7c32d32a7315f (patch)
tree13ce28792fd522bb03adba80cfbe8b1b280a2dd1 /www/p5-WWW-Shorten-Googl
parentbbdbc3dc770b074110bd2fdcbf37d287ae8dc139 (diff)
downloadports-0f27a63339f1953b9eade79421a7c32d32a7315f.tar.gz
ports-0f27a63339f1953b9eade79421a7c32d32a7315f.zip
A Perl interface to the goo.gl URL shortening service. Googl simply
maintains a database of long URLs, each of which has a unique identifier. WWW: http://search.cpan.org/dist/WWW-Shorten-Googl/ PR: ports/160607 Submitted by: Jonathan Pater <cowboyneal@gmail.com>
Notes
Notes: svn path=/head/; revision=281548
Diffstat (limited to 'www/p5-WWW-Shorten-Googl')
-rw-r--r--www/p5-WWW-Shorten-Googl/Makefile27
-rw-r--r--www/p5-WWW-Shorten-Googl/distinfo2
-rw-r--r--www/p5-WWW-Shorten-Googl/pkg-descr4
-rw-r--r--www/p5-WWW-Shorten-Googl/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/www/p5-WWW-Shorten-Googl/Makefile b/www/p5-WWW-Shorten-Googl/Makefile
new file mode 100644
index 000000000000..4aae5f70fed4
--- /dev/null
+++ b/www/p5-WWW-Shorten-Googl/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-WWW-Shorten-Googl
+# Date created: September 9 2011
+# Whom: Jonathan Pater <cowboyneal@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Shorten-Googl
+PORTVERSION= 1.02
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cowboyneal@gmail.com
+COMMENT= Perl interface to goo.gl
+
+BUILD_DEPENDS= p5-WWW-Shorten>=1.98:${PORTSDIR}/www/p5-WWW-Shorten \
+ p5-libwww>=5.75:${PORTSDIR}/www/p5-libwww \
+ p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-JSON-Any>=0:${PORTSDIR}/converters/p5-JSON-Any
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Shorten::Googl.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-Shorten-Googl/distinfo b/www/p5-WWW-Shorten-Googl/distinfo
new file mode 100644
index 000000000000..853230b6ea3b
--- /dev/null
+++ b/www/p5-WWW-Shorten-Googl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-Shorten-Googl-1.02.tar.gz) = 1c487d3b4146db56ad1736f937bc1021ae6c0726ea5c000686465c1887f8e3ba
+SIZE (WWW-Shorten-Googl-1.02.tar.gz) = 11183
diff --git a/www/p5-WWW-Shorten-Googl/pkg-descr b/www/p5-WWW-Shorten-Googl/pkg-descr
new file mode 100644
index 000000000000..93217ba862a3
--- /dev/null
+++ b/www/p5-WWW-Shorten-Googl/pkg-descr
@@ -0,0 +1,4 @@
+A Perl interface to the goo.gl URL shortening service. Googl simply
+maintains a database of long URLs, each of which has a unique identifier.
+
+WWW: http://search.cpan.org/dist/WWW-Shorten-Googl/
diff --git a/www/p5-WWW-Shorten-Googl/pkg-plist b/www/p5-WWW-Shorten-Googl/pkg-plist
new file mode 100644
index 000000000000..e5c01c533524
--- /dev/null
+++ b/www/p5-WWW-Shorten-Googl/pkg-plist
@@ -0,0 +1,8 @@
+bin/goo.gl
+%%SITE_PERL%%/WWW/Shorten/Googl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Googl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten/Googl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Shorten
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW/Shorten
+@dirrmtry %%SITE_PERL%%/WWW