aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WWW-VenusEnvy/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 02:25:46 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 02:25:46 +0000
commitec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a (patch)
tree3fd8d82e3c84a21104f1f2205ba3c8431096c9d8 /www/p5-WWW-VenusEnvy/Makefile
parent19a8c3cc6a281e5ad0b821cc21a6b8b043a72c8e (diff)
downloadports-ec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a.tar.gz
ports-ec4b5ec340ffc8e9ac42cdf926ce9e5e1445cc6a.zip
Add p5-WWW-VenusEnvy 1.10, venusEnvy comic strip archive and retrieval
module. PR: ports/100378 Submitted by: chinsan <chinsan.tw at gmail.com>, Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=168198
Diffstat (limited to 'www/p5-WWW-VenusEnvy/Makefile')
-rw-r--r--www/p5-WWW-VenusEnvy/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/p5-WWW-VenusEnvy/Makefile b/www/p5-WWW-VenusEnvy/Makefile
new file mode 100644
index 000000000000..c1f6e21d3ace
--- /dev/null
+++ b/www/p5-WWW-VenusEnvy/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-WWW-VenusEnvy
+# Date created: 2006/06/28
+# Whom: chinsan <chinsan.tw@gmail.com>, Gea-Suan Lin <gslin@gslin.org>
+# Thanks to Gea-Suan Lin for his great patch for this port.
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-VenusEnvy
+PORTVERSION= 1.10
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= VenusEnvy comic strip archive and retrieval module
+
+RUN_DEPENDS= p5-Test-Pod>=1.24:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.08:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= WWW::VenusEnvy.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from www/p5-libwww
+IGNORE= requires at least Perl 5.6.0. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>