aboutsummaryrefslogtreecommitdiff
path: root/www/p5-Web-Machine/Makefile
diff options
context:
space:
mode:
authorMikael Urankar <mikael@FreeBSD.org>2020-07-24 10:06:55 +0000
committerMikael Urankar <mikael@FreeBSD.org>2020-07-24 10:06:55 +0000
commit1faef800067c3277daf6899980f2d803eaf5c12f (patch)
treec56b3ce01aa14d40c0de99d741dd107ce7c176e1 /www/p5-Web-Machine/Makefile
parentd49fcf66ab5db9488129c665712f88b585817c2e (diff)
downloadports-1faef800067c3277daf6899980f2d803eaf5c12f.tar.gz
ports-1faef800067c3277daf6899980f2d803eaf5c12f.zip
www/p5-Web-Machine: create port
Web::Machine provides a RESTful web framework modeled as a state machine. You define one or more resource classes. Each resource represents a single RESTful URI end point, such as a user, an email, etc. The resource class can also be the target for POST requests to create a new user, email, etc. Each resource is a state machine, and each request for a resource is handled by running the request through that state machine. Web::Machine is built on top of Plack, but it handles the full request and response cycle. PR: 248041
Notes
Notes: svn path=/head/; revision=543237
Diffstat (limited to 'www/p5-Web-Machine/Makefile')
-rw-r--r--www/p5-Web-Machine/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/www/p5-Web-Machine/Makefile b/www/p5-Web-Machine/Makefile
new file mode 100644
index 000000000000..850d9edb35a8
--- /dev/null
+++ b/www/p5-Web-Machine/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= Web-Machine
+PORTVERSION= 0.17
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mikael@FreeBSD.org
+COMMENT= Perl port of Webmachine
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+RUN_DEPENDS= p5-HTTP-Headers-ActionPack>0:www/p5-HTTP-Headers-ActionPack \
+ p5-IO-Handle-Util>0:devel/p5-IO-Handle-Util
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>