aboutsummaryrefslogtreecommitdiff
path: root/www/p5-WebService-Pushover
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-01 16:23:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-08-01 16:23:35 +0000
commit073f3229f6a5a7ed5916e4c4b2459a2773210f11 (patch)
tree0e65b21d573af39ec5faa643ed614c517930b8c7 /www/p5-WebService-Pushover
parente6663c15cf95c6d67013c8f79c0f4bf937f0cb86 (diff)
downloadports-073f3229f6a5a7ed5916e4c4b2459a2773210f11.tar.gz
ports-073f3229f6a5a7ed5916e4c4b2459a2773210f11.zip
- Update to 0.2.0
- Add LICENSE - Add BUILD_DEPENDS - Sort PLIST - Reformat pkg-descr Changes: http://search.cpan.org/dist/WebService-Pushover/Changes
Notes
Notes: svn path=/head/; revision=363729
Diffstat (limited to 'www/p5-WebService-Pushover')
-rw-r--r--www/p5-WebService-Pushover/Makefile20
-rw-r--r--www/p5-WebService-Pushover/distinfo4
-rw-r--r--www/p5-WebService-Pushover/pkg-descr8
-rw-r--r--www/p5-WebService-Pushover/pkg-plist7
4 files changed, 25 insertions, 14 deletions
diff --git a/www/p5-WebService-Pushover/Makefile b/www/p5-WebService-Pushover/Makefile
index 43f1aec12c44..20237594fee7 100644
--- a/www/p5-WebService-Pushover/Makefile
+++ b/www/p5-WebService-Pushover/Makefile
@@ -2,22 +2,32 @@
# $FreeBSD$
PORTNAME= WebService-Pushover
-DISTVERSION= v0.0.6
+PORTVERSION= 0.2.0
CATEGORIES= www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Interface to Pushover API
-RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-Moo>=0:${PORTSDIR}/devel/p5-Moo \
+ p5-Net-HTTP-Spore>=0:${PORTSDIR}/net/p5-Net-HTTP-Spore \
+ p5-Net-HTTP-Spore-Middleware-Header>=0:${PORTSDIR}/net/p5-Net-HTTP-Spore-Middleware-Header \
p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
p5-Readonly>=0:${PORTSDIR}/devel/p5-Readonly \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-WebService-Simple>=0:${PORTSDIR}/www/p5-WebService-Simple
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
+ p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
-USES= perl5
USE_PERL5= configure
+USES= perl5
.include <bsd.port.mk>
diff --git a/www/p5-WebService-Pushover/distinfo b/www/p5-WebService-Pushover/distinfo
index 320e5ff7214f..db44679cf96b 100644
--- a/www/p5-WebService-Pushover/distinfo
+++ b/www/p5-WebService-Pushover/distinfo
@@ -1,2 +1,2 @@
-SHA256 (WebService-Pushover-v0.0.6.tar.gz) = f35d5cb75564fa91649c63b0d2519c877c261d820850c0ea407b13a0e8ef8eb3
-SIZE (WebService-Pushover-v0.0.6.tar.gz) = 6677
+SHA256 (WebService-Pushover-v0.2.0.tar.gz) = 41b30b46cf411c03406cb71f87f9afa68764f6d67c725b05359b5d19c90671e2
+SIZE (WebService-Pushover-v0.2.0.tar.gz) = 9972
diff --git a/www/p5-WebService-Pushover/pkg-descr b/www/p5-WebService-Pushover/pkg-descr
index 9352453c0c3d..0678851866b6 100644
--- a/www/p5-WebService-Pushover/pkg-descr
+++ b/www/p5-WebService-Pushover/pkg-descr
@@ -1,6 +1,6 @@
-This module provides a Perl wrapper around the Pushover
-( http://pushover.net ) RESTful API. You'll need to register with Pushover to
-obtain an API token for yourself and for your application before you'll be
-able to do anything with this module.
+This module provides a Perl wrapper around the Pushover ( http://pushover.net )
+RESTful API. You'll need to register with Pushover to obtain an API token for
+yourself and for your application before you'll be able to do anything with this
+module.
WWW: http://search.cpan.org/dist/WebService-Pushover/
diff --git a/www/p5-WebService-Pushover/pkg-plist b/www/p5-WebService-Pushover/pkg-plist
index 58db3abde3ae..4d0d55345572 100644
--- a/www/p5-WebService-Pushover/pkg-plist
+++ b/www/p5-WebService-Pushover/pkg-plist
@@ -1,6 +1,7 @@
-%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Pushover/.packlist
+%%SITE_PERL%%/WebService/Pushover.json
%%SITE_PERL%%/WebService/Pushover.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Pushover/.packlist
%%PERL5_MAN3%%/WebService::Pushover.3.gz
-@dirrmtry %%SITE_PERL%%/WebService
-@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Pushover
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService/Pushover
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WebService
+@dirrmtry %%SITE_PERL%%/WebService