aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libwww
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-05-01 00:50:41 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-05-01 00:50:41 +0000
commit1aa45a323b9d706fd21c07bbbe4ba1865bbcb732 (patch)
tree034cdb01a0f50cceeff8b72d872817d84fe66e72 /www/p5-libwww
parentbcc578974aa65cf9631aacd89e26a47b14f6ee3e (diff)
downloadports-1aa45a323b9d706fd21c07bbbe4ba1865bbcb732.tar.gz
ports-1aa45a323b9d706fd21c07bbbe4ba1865bbcb732.zip
- Fix pkg-plist
- Take over as MAINTAINER - Fix formatting in Makefile PR: 27000 Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=42114
Diffstat (limited to 'www/p5-libwww')
-rw-r--r--www/p5-libwww/Makefile40
-rw-r--r--www/p5-libwww/pkg-descr4
-rw-r--r--www/p5-libwww/pkg-plist12
3 files changed, 19 insertions, 37 deletions
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index 0f202ecdeca8..fda5c3c7d6c7 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= LWP
DISTNAME= libwww-perl-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= petef@databits.net
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MD5.pm:${PORTSDIR}/security/p5-MD5 \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI \
@@ -23,35 +23,15 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MAN1= lwp-download.1 \
- lwp-mirror.1 \
- lwp-request.1 \
- lwp-rget.1
-MAN3= Bundle::LWP.3 \
- File::Listing.3 \
- HTML::Form.3 \
- HTTP::Cookies.3 \
- HTTP::Daemon.3 \
- HTTP::Date.3 \
- HTTP::Headers.3 \
- HTTP::Headers::Util.3 \
- HTTP::Message.3 \
- HTTP::Negotiate.3 \
- HTTP::Request.3 \
- HTTP::Request::Common.3 \
- HTTP::Response.3 \
- HTTP::Status.3 \
- LWP.3 \
- LWP::Debug.3 \
- LWP::MediaTypes.3 \
- LWP::MemberMixin.3 \
- LWP::Protocol.3 \
- LWP::RobotUA.3 \
- LWP::Simple.3 \
- LWP::UserAgent.3 \
- WWW::RobotRules.3 \
- WWW::RobotRules::AnyDBM_File.3 \
- lwpcook.3
+MAN1= lwp-download.1 lwp-mirror.1 lwp-request.1 lwp-rget.1
+
+MAN3= Bundle::LWP.3 File::Listing.3 HTML::Form.3 HTTP::Cookies.3 \
+ HTTP::Daemon.3 HTTP::Date.3 HTTP::Headers.3 HTTP::Headers::Util.3 \
+ HTTP::Message.3 HTTP::Negotiate.3 HTTP::Request.3 \
+ HTTP::Request::Common.3 HTTP::Response.3 HTTP::Status.3 LWP.3 \
+ LWP::Debug.3 LWP::MediaTypes.3 LWP::MemberMixin.3 LWP::Protocol.3 \
+ LWP::RobotUA.3 LWP::Simple.3 LWP::UserAgent.3 WWW::RobotRules.3 \
+ WWW::RobotRules::AnyDBM_File.3 lwpcook.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/www/p5-libwww/pkg-descr b/www/p5-libwww/pkg-descr
index e029d82a3ef4..18a0c090a6c6 100644
--- a/www/p5-libwww/pkg-descr
+++ b/www/p5-libwww/pkg-descr
@@ -4,13 +4,13 @@
provide classes and functions that allow you to write WWW
clients, thus libwww-perl said to be a WWW client library.
The library also contain modules that are of more general
- use.
+ use.
The main architecture of the library is object oriented.
The user agent, requests sent and responses received from
the WWW server are all represented by objects. This makes
a simple and powerful interface to these services. The
interface should be easy to extend and customize for your
- needs.
+ needs.
WWW: http://www.linpro.no/lwp/
diff --git a/www/p5-libwww/pkg-plist b/www/p5-libwww/pkg-plist
index 93bc6aa420b3..b4199b2ed847 100644
--- a/www/p5-libwww/pkg-plist
+++ b/www/p5-libwww/pkg-plist
@@ -42,18 +42,20 @@ lib/perl5/site_perl/%%PERL_VER%%/LWP/RobotUA.pm
lib/perl5/site_perl/%%PERL_VER%%/LWP/Simple.pm
lib/perl5/site_perl/%%PERL_VER%%/LWP/UserAgent.pm
lib/perl5/site_perl/%%PERL_VER%%/LWP/media.types
+lib/perl5/site_perl/%%PERL_VER%%/Net/HTTP.pm
lib/perl5/site_perl/%%PERL_VER%%/WWW/RobotRules.pm
lib/perl5/site_perl/%%PERL_VER%%/WWW/RobotRules/AnyDBM_File.pm
lib/perl5/site_perl/%%PERL_VER%%/lwpcook.pod
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libwww-perl/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/WWW/RobotRules
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/WWW 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Authen
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Protocol
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/LWP 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/HTTP/Headers
@dirrm lib/perl5/site_perl/%%PERL_VER%%/HTTP/Request
@dirrm lib/perl5/site_perl/%%PERL_VER%%/HTTP
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Authen
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP/Protocol
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/LWP
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/WWW/RobotRules
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/WWW
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/libwww-perl
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/File 2>/dev/null || true