aboutsummaryrefslogtreecommitdiff
path: root/www/p5-libwww
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-10-03 00:47:57 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-10-03 00:47:57 +0000
commit59d463b83c3894f3bba31758b4fdc7df61ca5d58 (patch)
treef40efc005436b29283e34c383a0eadb3895f33fa /www/p5-libwww
parent0d967c2b1050934a8c6a06c7c7849bf518e9a316 (diff)
downloadports-59d463b83c3894f3bba31758b4fdc7df61ca5d58.tar.gz
ports-59d463b83c3894f3bba31758b4fdc7df61ca5d58.zip
- simplify dependencies
- bump PORTREVISION
Notes
Notes: svn path=/head/; revision=221144
Diffstat (limited to 'www/p5-libwww')
-rw-r--r--www/p5-libwww/Makefile29
1 files changed, 16 insertions, 13 deletions
diff --git a/www/p5-libwww/Makefile b/www/p5-libwww/Makefile
index 1a64008c8d3c..3f383c27f0a4 100644
--- a/www/p5-libwww/Makefile
+++ b/www/p5-libwww/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libwww
PORTVERSION= 5.816
+PORTREVISION= 1
CATEGORIES= www perl5 devel
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= LWP
@@ -16,16 +17,11 @@ DISTNAME= libwww-perl-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 library for WWW access
-BUILD_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI
PERL_CONFIGURE= yes
-CONFIGURE_ARGS+= --aliases
+CONFIGURE_ARGS= --aliases
MAN1= GET.1 HEAD.1 POST.1 lwp-download.1 lwp-mirror.1 lwp-request.1 lwp-rget.1
@@ -41,9 +37,16 @@ MAN3= Bundle::LWP.3 File::Listing.3 HTML::Form.3 HTTP::Config.3 \
LWP::UserAgent.3 Net::HTTP.3 Net::HTTP::NB.3 WWW::RobotRules.3 \
WWW::RobotRules::AnyDBM_File.3 lwpcook.3 lwptut.3
-post-patch:
- @${PERL} -pi -e "s,/usr/lib/sendmail,/usr/sbin/sendmail," \
- ${WRKSRC}/lib/LWP/Protocol/mailto.pm
- @${PERL} -pi -e 's!(?=prompt\()!1 || !g' ${WRKSRC}/Makefile.PL
+.include <bsd.port.pre.mk>
-.include <bsd.port.mk>
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Net>=2.58:${PORTSDIR}/net/p5-Net
+.endif
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-Compress-Zlib>=1.10:${PORTSDIR}/archivers/p5-Compress-Zlib
+.endif
+
+.include <bsd.port.post.mk>