aboutsummaryrefslogtreecommitdiff
path: root/www/pear-HTTP_Download
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-19 10:42:15 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-19 10:42:15 +0000
commit7cfc2dc3e27e5dc8f474add018542b762a10be78 (patch)
treec688145efb8d5fb42138687fd3f807a30a980058 /www/pear-HTTP_Download
parent07bcbad649aa20a7be60da6e67e940f80cfd92bc (diff)
downloadports-7cfc2dc3e27e5dc8f474add018542b762a10be78.tar.gz
ports-7cfc2dc3e27e5dc8f474add018542b762a10be78.zip
New port: www/pear-HTTP_Download PEAR class to send HTTP downloads
Provides an interface to easily send hidden files or any arbitrary data to HTTP clients. HTTP_Download can gain its data from variables, files or stream resources. It features: - Basic caching capabilities - Basic throttling mechanism - On-the-fly gzip-compression - Ranges (partial downloads and resuming) - Delivery of on-the-fly generated archives through Archive_Tar and Archive_Zip PR: ports/76366 Submitted by: Antônio Carlos Venâncio Júnior <antonio@php.net>
Notes
Notes: svn path=/head/; revision=126813
Diffstat (limited to 'www/pear-HTTP_Download')
-rw-r--r--www/pear-HTTP_Download/Makefile44
-rw-r--r--www/pear-HTTP_Download/distinfo2
-rw-r--r--www/pear-HTTP_Download/pkg-descr13
3 files changed, 59 insertions, 0 deletions
diff --git a/www/pear-HTTP_Download/Makefile b/www/pear-HTTP_Download/Makefile
new file mode 100644
index 000000000000..bfcf886153b3
--- /dev/null
+++ b/www/pear-HTTP_Download/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: pear-HTTP_Download
+# Date created: 17 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTTP_Download
+PORTVERSION= 1.0.0.r3
+CATEGORIES= www devel pear
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/RC/}
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class to send HTTP downloads
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Header.php:${PORTSDIR}/www/pear-HTTP_Header
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+LATEST_LINK= pear-HTTP_Download
+OPTIONS= PEAR_ARCHIVE_TAR "PEAR::Archive_Tar support" off
+
+CATEGORY= HTTP
+FILES= Download.php Download/PgLOB.php
+TESTS= send.php testcase.php data.txt
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 420
+IGNORE= "You need PHP 4.2.0 or later to install PEAR::HTTP_Download"
+.endif
+
+.if defined(WITH_PEAR_ARCHIVE_TAR)
+BUILD_DEPENDS+= ${PEARDIR}/Archive/Tar.php:${PORTSDIR}/archivers/pear-Archive_Tar
+.endif
+
+do-build:
+ ${NADA}
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/www/pear-HTTP_Download/distinfo b/www/pear-HTTP_Download/distinfo
new file mode 100644
index 000000000000..bb800f1a02ba
--- /dev/null
+++ b/www/pear-HTTP_Download/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTTP_Download-1.0.0RC3.tgz) = b16c94912baf4a7608278cd6f18e1236
+SIZE (PEAR/HTTP_Download-1.0.0RC3.tgz) = 10445
diff --git a/www/pear-HTTP_Download/pkg-descr b/www/pear-HTTP_Download/pkg-descr
new file mode 100644
index 000000000000..1f4ce79c08b4
--- /dev/null
+++ b/www/pear-HTTP_Download/pkg-descr
@@ -0,0 +1,13 @@
+Provides an interface to easily send hidden files or any arbitrary data to
+HTTP clients. HTTP_Download can gain its data from variables, files or
+stream resources.
+
+It features:
+- Basic caching capabilities
+- Basic throttling mechanism
+- On-the-fly gzip-compression
+- Ranges (partial downloads and resuming)
+- Delivery of on-the-fly generated archives through Archive_Tar and
+Archive_Zip
+
+WWW: http://pear.php.net/package/HTTP_Download/