aboutsummaryrefslogtreecommitdiff
path: root/www/pear-Services_Yadis
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-01-23 14:21:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-01-23 14:21:56 +0000
commit9e4d5d5178d74c7f635623870c26d3cf66e554ff (patch)
tree49e1288adb983a4cf712f81b3b8cf29f8f22d359 /www/pear-Services_Yadis
parent2f747b6048f4adf133b3feb939f31d5b6d3733f3 (diff)
downloadports-9e4d5d5178d74c7f635623870c26d3cf66e554ff.tar.gz
ports-9e4d5d5178d74c7f635623870c26d3cf66e554ff.zip
Implementation of the Yadis Specification 1.0 protocol allowing a client to
discover a list of Services a Yadis Identity Provider offers. WWW: http://pear.php.net/package/Services_Yadis/ PR: ports/119858 Submitted by: Ditesh Shashikant Gathani <ditesh at gathani.org>
Notes
Notes: svn path=/head/; revision=206068
Diffstat (limited to 'www/pear-Services_Yadis')
-rw-r--r--www/pear-Services_Yadis/Makefile31
-rw-r--r--www/pear-Services_Yadis/distinfo3
-rw-r--r--www/pear-Services_Yadis/pkg-descr4
3 files changed, 38 insertions, 0 deletions
diff --git a/www/pear-Services_Yadis/Makefile b/www/pear-Services_Yadis/Makefile
new file mode 100644
index 000000000000..811d44750fdb
--- /dev/null
+++ b/www/pear-Services_Yadis/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: pear-Services_Yadis
+# Date created: 21 Jan 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_Yadis
+PORTVERSION= 0.2.1
+CATEGORIES= www pear
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= Implementation of the Yadis Specification 1.0 protocol for PHP5
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+CATEGORY= Services
+FILES= Yadis.php Yadis/Xri.php Yadis/Xrds.php Yadis/Service.php \
+ Yadis/Exception.php Yadis/Xrds/Namespace.php \
+ Yadis/Xrds/Service.php
+
+TESTS= test.php
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/tests
+ ${MV} ${WRKSRC}/test.php ${WRKSRC}/tests
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/www/pear-Services_Yadis/distinfo b/www/pear-Services_Yadis/distinfo
new file mode 100644
index 000000000000..1315623d3b01
--- /dev/null
+++ b/www/pear-Services_Yadis/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_Yadis-0.2.1.tgz) = 5b4d3ed2b0152ac7274fcec3284990db
+SHA256 (PEAR/Services_Yadis-0.2.1.tgz) = c3730f53ce0476f6cd1c458eda6a98c2a44058bc5c47bf1eb917a887de2ebb38
+SIZE (PEAR/Services_Yadis-0.2.1.tgz) = 12895
diff --git a/www/pear-Services_Yadis/pkg-descr b/www/pear-Services_Yadis/pkg-descr
new file mode 100644
index 000000000000..27a835cf73dc
--- /dev/null
+++ b/www/pear-Services_Yadis/pkg-descr
@@ -0,0 +1,4 @@
+Implementation of the Yadis Specification 1.0 protocol allowing a client to
+discover a list of Services a Yadis Identity Provider offers.
+
+WWW: http://pear.php.net/package/Services_Yadis/