aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-APC/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-06 18:25:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-06 18:25:55 +0000
commit0a39e9f6ad51a824ab99eb287606973feefada0f (patch)
tree27659baad8f45970bb72aba9b2ab1ccbfb797137 /www/pecl-APC/Makefile
parent5b19c4c93dffc75510971916769413fcb740a19c (diff)
downloadports-0a39e9f6ad51a824ab99eb287606973feefada0f.tar.gz
ports-0a39e9f6ad51a824ab99eb287606973feefada0f.zip
- Update to 3.0.2
PR: ports/83069 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=138619
Diffstat (limited to 'www/pecl-APC/Makefile')
-rw-r--r--www/pecl-APC/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/www/pecl-APC/Makefile b/www/pecl-APC/Makefile
index 6db97265a31e..1eea17764e98 100644
--- a/www/pecl-APC/Makefile
+++ b/www/pecl-APC/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= APC
-PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTVERSION= 3.0.2
CATEGORIES= www
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -18,7 +17,6 @@ MAINTAINER= marcus@corp.grupos.com.br
COMMENT= Alternative PHP Cache
USE_PHP= yes
-USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= apc
@@ -29,19 +27,28 @@ CONFIGURE_ARGS= --enable-apc
OPTIONS= MMAP "Enable mmap memory support (default: IPC shm)" off \
SEMAPHORES "Enable sysv IPC semaphores (default: fcntl())" off \
+ PHP4_OPT "Little optimization for PHP4" off
.include <bsd.port.pre.mk>
-.if ${PHP_VER} == 5
-BROKEN= This port is not compatible with php${PHP_VER}
+.if defined(WITH_MMAP)
+CONFIGURE_ARGS+= --enable-apc-mmap
.endif
-.if !defined(WITHOUT_MMAP)
-CONFIGURE_ARGS+= --enable-mmap
+.if defined(WITH_SEMAPHORES)
+CONFIGURE_ARGS+= --enable-apc-sem
.endif
-.if !defined(WITHOUT_SEMAPHORES)
-CONFIGURE_ARGS+= --enable-sem
+.if defined(WITH_PHP4_OPT)
+.if ${PHP_VER} == 4
+.if exists(${LOCALBASE}/include/apache/httpd.h)
+CFLAGS+= -I${LOCALBASE}/include/apache -DAPC_PHP4_STAT
+.elif exists(${LOCALBASE}/include/apache2/httpd.h)
+CFLAGS+= -I${LOCALBASE}/include/apache -DAPC_PHP4_STAT
+.endif
+.else
+IGNORE= This optimization is only for PHP4. PHP5 or newer does not need it
+.endif
.endif
.if !defined(NOPORTDOCS)