aboutsummaryrefslogtreecommitdiff
path: root/www/php-templates
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-19 07:42:41 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-19 07:42:41 +0000
commit36be6c7cc4283ec34f88ce4725fa4438be7765ac (patch)
treebc51861eca74afe2aa615c07a66f7c51f3b3f8cc /www/php-templates
parent15fad87b64361a59c7fe9614971ec516b06821d9 (diff)
downloadports-36be6c7cc4283ec34f88ce4725fa4438be7765ac.tar.gz
ports-36be6c7cc4283ec34f88ce4725fa4438be7765ac.zip
Convert from USE_DOS2UNIX to USES=dos2unix
While here: - support stage, - use bsdtar to extract when supported. - Cleanup
Notes
Notes: svn path=/head/; revision=334286
Diffstat (limited to 'www/php-templates')
-rw-r--r--www/php-templates/Makefile20
1 files changed, 6 insertions, 14 deletions
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index 361f64b03051..92536d76dbd8 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -8,15 +8,13 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.7:ext \
SF/${PORTNAME}/${PORTNAME}-doc/html:doc
DISTNAME= php_templates-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:ext
-.if !defined(NOPORTDOCS)
DISTFILES+= php_templates-doc-eng-1.1${EXTRACT_SUFX}:doc
-.endif
MAINTAINER= ports@FreeBSD.org
-COMMENT= A template framework for PHP
+COMMENT= Template framework for PHP
WRKSRC= ${WRKDIR}/templates
-USE_DOS2UNIX= yes
+USES= dos2unix
USE_PHP= yes
USE_PHPIZE= yes
@@ -27,17 +25,11 @@ SUB_FILES= pkg-message
PORTDOCS= *
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/php/${PHP_EXT_DIR}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}
@${INSTALL_DATA} ${WRKSRC}/modules/templates.so \
- ${PREFIX}/lib/php/${PHP_EXT_DIR}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}-doc/* ${DOCSDIR}
-.endif
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${STAGEDIR}${PREFIX}/lib/php/${PHP_EXT_DIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${INSTALL_DATA} ${STAGEDIR}${WRKSRC}-doc/* ${DOCSDIR}
.include <bsd.port.mk>