aboutsummaryrefslogtreecommitdiff
path: root/www/phpwiki13
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-12-19 21:24:39 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-12-19 21:24:39 +0000
commit5f532d121b602c3eac1f043a7b2d59fbf23cf8df (patch)
tree30442d4be9a795a689713a7038659db34569121d /www/phpwiki13
parent539071e5cd0c6e12fe056ab74c1561dd9fbc77d2 (diff)
downloadports-5f532d121b602c3eac1f043a7b2d59fbf23cf8df.tar.gz
ports-5f532d121b602c3eac1f043a7b2d59fbf23cf8df.zip
- added OPTIONS
PR: 90101 Submitted by: Babak Farrokhi Approved by: tobez
Notes
Notes: svn path=/head/; revision=151597
Diffstat (limited to 'www/phpwiki13')
-rw-r--r--www/phpwiki13/Makefile45
-rw-r--r--www/phpwiki13/files/pkg-message.in13
-rw-r--r--www/phpwiki13/pkg-plist35
3 files changed, 68 insertions, 25 deletions
diff --git a/www/phpwiki13/Makefile b/www/phpwiki13/Makefile
index 358ec4175495..62520b390b6a 100644
--- a/www/phpwiki13/Makefile
+++ b/www/phpwiki13/Makefile
@@ -7,6 +7,7 @@
PORTNAME= phpwiki
PORTVERSION= 1.3.11p1
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= phpwiki
@@ -17,24 +18,50 @@ COMMENT= A PHP WikiWikiWeb
CONFLICTS+= phpwiki-1.2*
LATEST_LINK= phpwiki13
-.if !defined(WITHOUT_PHP_DEPENDS)
USE_PHP= ctype pcre posix session tokenizer xml zlib mysql
-.if defined(WITH_CDB) || defined(WITH_DB4) || defined(WITH_GDBM) || defined(WITH_INIFILE)
-USE_PHP+= dba
-.endif
-.endif
NO_BUILD= YES
PHP4_PORT?= www/mod_php4
PHPWIKI?= www/data-dist/phpwiki
PLIST_SUB+= PHPWIKI=${PHPWIKI}
+SUB_FILES= pkg-message
ROOTFILES= GoogleSearch.wsdl PhpWiki.wsdl RPC2.php SOAP.php \
configurator.php favicon.ico getimg.php gforge.php \
index.php passencrypt.php wiki
-ROOTDIRS= config doc lib locale pgsrc schemas tests themes uploads
+ROOTDIRS= config lib locale pgsrc schemas tests themes uploads
DOCFILES= INSTALL LICENSE README TODO UPGRADING
-do-configure:
+OPTIONS= MYSQL "Use MySQL backend" on \
+ PGSQL "Use PostgreSQL backend" off \
+ DB4 "Use Berkeley DB4 backend" off
+
+.if defined(PHP_VER) && ${PHP_VER} == 5
+OPTIONS+= SQLITE "Use SQLite backend" off
+.endif
+
+PORT_DBDIR?= /var/db/ports
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+OPTIONSFILE?= ${PORT_DBDIR}/${LATEST_LINK}/options
+
+.if exists(${OPTIONSFILE})
+.include "${OPTIONSFILE}"
+.endif
+
+.if defined(WITH_DB4)
+USE_PHP+= dba
+.endif
+
+.if !defined(WITHOUT_MYSQL)
+USE_PHP+= mysql
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.if defined(WITH_SQLITE)
+USE_PHP+= sqlite
+.endif
do-install:
-${MKDIR} ${PREFIX}/${PHPWIKI}
@@ -48,6 +75,10 @@ do-install:
.for i in ${DOCFILES}
@${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/${i}
.endfor
+ @(cd ${WRKSRC} && ${CP} -R doc/* ${DOCSDIR}/ )
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.mk>
diff --git a/www/phpwiki13/files/pkg-message.in b/www/phpwiki13/files/pkg-message.in
new file mode 100644
index 000000000000..42b684eaba5b
--- /dev/null
+++ b/www/phpwiki13/files/pkg-message.in
@@ -0,0 +1,13 @@
+
+===========================================================
+
+* If this is your first install, read the installation
+ instructions to setup your database, located at:
+ %%DOCSDIR%%/INSTALL.*:
+
+* If you are upgrading from an older version of phpwiki, please
+ read upgrade instructions located at:
+ %%DOCSDIR%%/UPGRADING
+
+===========================================================
+
diff --git a/www/phpwiki13/pkg-plist b/www/phpwiki13/pkg-plist
index 6a71c265a5e4..f7e3bf8ccb55 100644
--- a/www/phpwiki13/pkg-plist
+++ b/www/phpwiki13/pkg-plist
@@ -3,6 +3,23 @@
%%DOCSDIR%%/README
%%DOCSDIR%%/TODO
%%DOCSDIR%%/UPGRADING
+%%DOCSDIR%%/CREDITS
+%%DOCSDIR%%/HISTORY
+%%DOCSDIR%%/INSTALL.MacOSX
+%%DOCSDIR%%/INSTALL.flatfile
+%%DOCSDIR%%/INSTALL.mSQL
+%%DOCSDIR%%/INSTALL.mysql
+%%DOCSDIR%%/INSTALL.oci8
+%%DOCSDIR%%/INSTALL.pgsql
+%%DOCSDIR%%/INSTALL.sqlite
+%%DOCSDIR%%/README.coding
+%%DOCSDIR%%/README.foaf
+%%DOCSDIR%%/README.fpdf
+%%DOCSDIR%%/README.phpwiki-auth
+%%DOCSDIR%%/README.phpwiki-cache
+%%DOCSDIR%%/README.security
+%%DOCSDIR%%/THEMES
+%%DOCSDIR%%/phpwiki_architecture.png
%%PHPWIKI%%/GoogleSearch.wsdl
%%PHPWIKI%%/PhpWiki.wsdl
%%PHPWIKI%%/RPC2.php
@@ -14,23 +31,6 @@
%%PHPWIKI%%/config/make-dbhelper.pl
%%PHPWIKI%%/config/phpwiki.spec
%%PHPWIKI%%/configurator.php
-%%PHPWIKI%%/doc/CREDITS
-%%PHPWIKI%%/doc/HISTORY
-%%PHPWIKI%%/doc/INSTALL.MacOSX
-%%PHPWIKI%%/doc/INSTALL.flatfile
-%%PHPWIKI%%/doc/INSTALL.mSQL
-%%PHPWIKI%%/doc/INSTALL.mysql
-%%PHPWIKI%%/doc/INSTALL.oci8
-%%PHPWIKI%%/doc/INSTALL.pgsql
-%%PHPWIKI%%/doc/INSTALL.sqlite
-%%PHPWIKI%%/doc/README.coding
-%%PHPWIKI%%/doc/README.foaf
-%%PHPWIKI%%/doc/README.fpdf
-%%PHPWIKI%%/doc/README.phpwiki-auth
-%%PHPWIKI%%/doc/README.phpwiki-cache
-%%PHPWIKI%%/doc/README.security
-%%PHPWIKI%%/doc/THEMES
-%%PHPWIKI%%/doc/phpwiki_architecture.png
%%PHPWIKI%%/favicon.ico
%%PHPWIKI%%/getimg.php
%%PHPWIKI%%/gforge.php
@@ -1616,7 +1616,6 @@
@dirrm %%PHPWIKI%%/lib/DbSession
@dirrm %%PHPWIKI%%/lib/ASCIIMathPHP
@dirrm %%PHPWIKI%%/lib
-@dirrm %%PHPWIKI%%/doc
@dirrm %%PHPWIKI%%/config
@dirrm %%PHPWIKI%%
@dirrm %%DOCSDIR%%