aboutsummaryrefslogtreecommitdiff
path: root/www/plugger
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-25 16:02:39 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-08-25 16:02:39 +0000
commitee2f77eb44190c6ddae9ef761b8f01bb9616fb54 (patch)
treebacc5003d594b7b0d2171252724c058fcef7a4f1 /www/plugger
parent38fe55b653afd74ec32101cc1e512cfb546aed99 (diff)
downloadports-ee2f77eb44190c6ddae9ef761b8f01bb9616fb54.tar.gz
ports-ee2f77eb44190c6ddae9ef761b8f01bb9616fb54.zip
Update plugger to depend/work with acroread5 instead of acroread4
PR: 41991 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=64983
Diffstat (limited to 'www/plugger')
-rw-r--r--www/plugger/Makefile8
-rw-r--r--www/plugger/files/patch-pluggerrc2
2 files changed, 7 insertions, 3 deletions
diff --git a/www/plugger/Makefile b/www/plugger/Makefile
index a3bd9884a480..380ba2c03c20 100644
--- a/www/plugger/Makefile
+++ b/www/plugger/Makefile
@@ -7,12 +7,13 @@
PORTNAME= plugger
PORTVERSION= 4.0
+PORTREVISION= 1
CATEGORIES= www audio graphics
MASTER_SITES= http://fredrik.hubbe.net/plugger/ \
ftp://ftp.netscape.com/pub/sdk/plugin/unix/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} unix-sdk-3.0b5.tar.Z
-MAINTAINER= jmcoopr@webmail.bmi.net
+MAINTAINER= coop9211@uidaho.edu
RUN_DEPENDS= ${X11BASE}/bin/mozilla:${PORTSDIR}/www/mozilla \
${X11BASE}/bin/xanim:${PORTSDIR}/graphics/xanim \
@@ -26,9 +27,10 @@ RUN_DEPENDS= ${X11BASE}/bin/mozilla:${PORTSDIR}/www/mozilla \
${X11BASE}/bin/gv:${PORTSDIR}/print/gv \
${X11BASE}/bin/abiword:${PORTSDIR}/editors/AbiWord \
${X11BASE}/bin/gnumeric:${PORTSDIR}/math/gnumeric \
- ${LOCALBASE}/bin/acroread4:${PORTSDIR}/print/acroread4
+ ${LOCALBASE}/bin/acroread5:${PORTSDIR}/print/acroread5
USE_X_PREFIX= yes
+USE_REINPLACE= yes
MAN7= plugger.7
MANCOMPRESSED= no
@@ -66,6 +68,8 @@ post-patch:
@${SED} \
-e 's#/usr/local/#${PREFIX}/#' \
${WRKSRC}/plugger.c.orig > ${WRKSRC}/plugger.c
+# CC safeness
+ @${REINPLACE_CMD} -e 's|CC=gcc|CC=${CC}|' ${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/plugger-${PORTVERSION} \
diff --git a/www/plugger/files/patch-pluggerrc b/www/plugger/files/patch-pluggerrc
index e2b0bb77c054..28715d7e1d8e 100644
--- a/www/plugger/files/patch-pluggerrc
+++ b/www/plugger/files/patch-pluggerrc
@@ -55,7 +55,7 @@
text/pdf: pdf: PDF file
text/x-pdf: pdf: PDF file
- repeat swallow(documentShell) fill: acroread -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
-+ repeat swallow(documentShell) fill: acroread4 -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
++ repeat swallow(documentShell) fill: acroread5 -geometry +9000+9000 -xrm '*userFrontEndProgram: FALSE' "$file"
repeat swallow(gv) fill: gv -safer -quiet -antialias -geometry +9000+9000 "$file" 2>/dev/null
repeat swallow(xpdf) fill: xpdf -g +9000+9000 -err "$file"