aboutsummaryrefslogtreecommitdiff
path: root/www/podcastamatic
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:17:14 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-13 09:17:14 +0000
commitfb1d43db730f569de5e196ae00ebc47221dd5b1c (patch)
tree66e36492bd94458e07ed1bd468eaaf11717cd92b /www/podcastamatic
parent073c6a731e40dea844d4723ebfcc7d14dd1cb97c (diff)
downloadports-fb1d43db730f569de5e196ae00ebc47221dd5b1c.tar.gz
ports-fb1d43db730f569de5e196ae00ebc47221dd5b1c.zip
Podcastamatic automates the creation of a webpage and a RSS feed
for your podcast, based on MP3 tags. A webpage can either be automatically generated from scratch or generated from a template you create. An RSS feed is an XML file that is required to be listed in most popular podcast directories. Podcastamatic is highly customizable. PR: ports/83331 Submitted by: Lars Eggert <lars.eggert@gmx.net>
Notes
Notes: svn path=/head/; revision=139041
Diffstat (limited to 'www/podcastamatic')
-rw-r--r--www/podcastamatic/Makefile43
-rw-r--r--www/podcastamatic/distinfo2
-rw-r--r--www/podcastamatic/pkg-descr7
-rw-r--r--www/podcastamatic/pkg-plist6
4 files changed, 58 insertions, 0 deletions
diff --git a/www/podcastamatic/Makefile b/www/podcastamatic/Makefile
new file mode 100644
index 000000000000..9dea6827f69d
--- /dev/null
+++ b/www/podcastamatic/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: podcastamatic
+# Date created: 12 July 2005
+# Whom: lars.eggert@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= podcastamatic
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://bradley.chicago.il.us/projects/podcastamatic/
+DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Automates creation of webpage and RSS feed for a podcast
+
+RUN_DEPENDS= ${SITE_PERL}/MP3/Info.pm:${PORTSDIR}/audio/p5-MP3-Info
+
+USE_ZIP= yes
+USE_PERL5_RUN= yes
+USE_REINPLACE= yes
+
+NO_BUILD= yes
+
+do-patch:
+ @${REINPLACE_CMD} -e "s|${PORTNAME}.conf|${PREFIX}/etc/${PORTNAME}.conf|"\
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/
+ @${MKDIR} ${PREFIX}/share/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/style.css ${PREFIX}/share/${PORTNAME}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.html ${DOCSDIR}
+.endif
+ @${ECHO}
+ @${ECHO} "Edit ${PREFIX}/etc/${PORTNAME}.conf"
+ @${ECHO} "CSS in ${PREFIX}/share/${PORTNAME}/style.css"
+ @${ECHO}
+
+.include <bsd.port.mk>
diff --git a/www/podcastamatic/distinfo b/www/podcastamatic/distinfo
new file mode 100644
index 000000000000..5f63ce510760
--- /dev/null
+++ b/www/podcastamatic/distinfo
@@ -0,0 +1,2 @@
+MD5 (podcastamatic1_2.zip) = 3014e2f50a809161f4ed799fd29eab00
+SIZE (podcastamatic1_2.zip) = 18891
diff --git a/www/podcastamatic/pkg-descr b/www/podcastamatic/pkg-descr
new file mode 100644
index 000000000000..ee334f5677a7
--- /dev/null
+++ b/www/podcastamatic/pkg-descr
@@ -0,0 +1,7 @@
+Podcastamatic automates the creation of a webpage and a RSS feed
+for your podcast, based on MP3 tags. A webpage can either be
+automatically generated from scratch or generated from a template
+you create. An RSS feed is an XML file that is required to be listed
+in most popular podcast directories. Podcastamatic is highly customizable.
+
+WWW: http://bradley.chicago.il.us/projects/podcastamatic/
diff --git a/www/podcastamatic/pkg-plist b/www/podcastamatic/pkg-plist
new file mode 100644
index 000000000000..9eeb3b363161
--- /dev/null
+++ b/www/podcastamatic/pkg-plist
@@ -0,0 +1,6 @@
+bin/podcastamatic
+etc/podcastamatic.conf
+%%PORTDOCS%%%%DOCSDIR%%/readme.html
+%%DATADIR%%/style.css
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%