aboutsummaryrefslogtreecommitdiff
path: root/www/pserv/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2005-05-28 09:08:44 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2005-05-28 09:08:44 +0000
commite63323d90203c910f5e65db7a164e6cef20dcb49 (patch)
treed0f6551e10a23472d2b6f03ff91638309965e981 /www/pserv/Makefile
parenta6a52769ec7277df95d38e0b0a4f531e95829d4f (diff)
downloadports-e63323d90203c910f5e65db7a164e6cef20dcb49.tar.gz
ports-e63323d90203c910f5e65db7a164e6cef20dcb49.zip
update to 3.3
change installation of etc/mime.types to etc/mime.types.pserv (stop conflicting with other ports) PR: ports/80726 Approved by: maintainer timeout (21 days)
Notes
Notes: svn path=/head/; revision=136326
Diffstat (limited to 'www/pserv/Makefile')
-rw-r--r--www/pserv/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/www/pserv/Makefile b/www/pserv/Makefile
index a5e3ab5d7794..41222052095b 100644
--- a/www/pserv/Makefile
+++ b/www/pserv/Makefile
@@ -6,18 +6,16 @@
#
PORTNAME= pserv
-PORTVERSION= 3.1
+PORTVERSION= 3.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-EXTRACT_SUFX= .tar.Z
MAINTAINER= ale@FreeBSD.org
COMMENT= A portable and small webserver written in C
-WRKSRC= ${WRKDIR}/${PORTNAME}
-BUILD_WRKSRC= ${WRKSRC}/sources
USE_REINPLACE= yes
+GNU_CONFIGURE= yes
OPTIONS= LOG "Enable logging" on \
PHP "Enable PHP support" on
@@ -26,7 +24,7 @@ OPTIONS= LOG "Enable logging" on \
post-patch:
@${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g;s|%%LOCALBASE%%|${LOCALBASE}|g" \
- ${WRKSRC}/defaults/pserv.conf
+ ${WRKSRC}/defaults/pserv.conf ${WRKSRC}/sources/main.h
.if defined(WITHOUT_LOG)
@${REINPLACE_CMD} "s|define LOG|undef LOG|" \
${WRKSRC}/sources/main.h
@@ -38,7 +36,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sources/pserv ${PREFIX}/sbin/
- ${INSTALL_DATA} ${WRKSRC}/defaults/mime_types.dat ${PREFIX}/etc/mime.types
+ ${INSTALL_DATA} ${WRKSRC}/defaults/mime_types.dat ${PREFIX}/etc/mime.types.pserv
${INSTALL_DATA} ${WRKSRC}/defaults/pserv.conf ${PREFIX}/etc/
${INSTALL_SCRIPT} ${FILESDIR}/pserv.sh ${PREFIX}/etc/rc.d/