aboutsummaryrefslogtreecommitdiff
path: root/www/py-aiohttp-middlewares/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-03 20:47:02 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-03 20:47:02 +0000
commitca44a51151a90deafd6fd3c41f339cd8dcf06b3f (patch)
treee0150c4adfcbb3a795ba908758064fef4a8eeb91 /www/py-aiohttp-middlewares/Makefile
parentba9b3f278f70142289a5385ec9bea4e945bd02f7 (diff)
downloadports-ca44a51151a90deafd6fd3c41f339cd8dcf06b3f.tar.gz
ports-ca44a51151a90deafd6fd3c41f339cd8dcf06b3f.zip
Add py-aiohttp-middlewares 1.1.0
aiohttp-middlewares is a collection of useful middlewares for aiohttp.web applications. By default aiohttp.web does not provide many built-in middlewares for standart web-development needs such as: handling errors, shielding view handlers, or providing CORS headers. aiohttp-middlewares tries to fix this by providing several middlewares that aims to cover most common web-development needs. WWW: https://github.com/playpauseandstop/aiohttp-middlewares
Notes
Notes: svn path=/head/; revision=533816
Diffstat (limited to 'www/py-aiohttp-middlewares/Makefile')
-rw-r--r--www/py-aiohttp-middlewares/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/www/py-aiohttp-middlewares/Makefile b/www/py-aiohttp-middlewares/Makefile
new file mode 100644
index 000000000000..db24a8a1f03a
--- /dev/null
+++ b/www/py-aiohttp-middlewares/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= aiohttp-middlewares
+PORTVERSION= 1.1.0
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Collection of useful middlewares for aiohttp applications
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.5<4.0:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}async_timeout>=1.2<4:devel/py-async_timeout@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>