aboutsummaryrefslogtreecommitdiff
path: root/www/py-bleach/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-08-30 04:01:24 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-08-30 04:01:24 +0000
commitc115dc0c5ff32d5b4feed1bab617b97de1183f78 (patch)
treee2d816fd693c8b3727a903a0f65d389bf363d82b /www/py-bleach/Makefile
parent23367d56b0d0c20d3f670937a89d818632f33580 (diff)
downloadports-c115dc0c5ff32d5b4feed1bab617b97de1183f78.tar.gz
ports-c115dc0c5ff32d5b4feed1bab617b97de1183f78.zip
www/py-bleach: Update to 1.4
- Update to 1.4 - Switch from GITHUB to CHEESESHOP for MASTER_SITES - Add BUILD_DEPENDS on six - Update minimum version for html5lib RUN_DEPENDS - Add TESTS option and tweak existing QA/Test entries - Modernize Python framework entries - Add LICENSE_FILE Changes: * https://github.com/jsocol/bleach/blob/v1.4/CHANGES PR: 146461 Submitted by: Muhammad Rahman <5u623l20 at gmail dotcom> (with changes)
Notes
Notes: svn path=/head/; revision=366588
Diffstat (limited to 'www/py-bleach/Makefile')
-rw-r--r--www/py-bleach/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/www/py-bleach/Makefile b/www/py-bleach/Makefile
index 5dfcc2f5c523..d779b4bacf82 100644
--- a/www/py-bleach/Makefile
+++ b/www/py-bleach/Makefile
@@ -2,30 +2,31 @@
# $FreeBSD$
PORTNAME= bleach
-PORTVERSION= 1.2.2
-PORTREVISION= 2
+PORTVERSION= 1.4
CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Easy whitelist-based HTML-sanitizing tool for Python
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0.95:${PORTSDIR}/www/py-html5lib
-TEST_DEPENDS:= ${RUN_DEPENDS} \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}html5lib>=0.95:${PORTSDIR}/www/py-html5lib \
nosetests:${PORTSDIR}/devel/py-nose
-USE_GITHUB= yes
-USE_PYTHON= yes
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
+OPTIONS_DEFINE= TESTS
-GH_ACCOUNT= jsocol
-GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= baf1eac
+TESTS_DESC= Install tools for test suite
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python
+USE_PYTHON= distutils autoplist
regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>