aboutsummaryrefslogtreecommitdiff
path: root/www/py-boto3/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:42:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-03-21 19:42:05 +0000
commite3b457db8a7be6504a432894a398fb17f8e0c1a7 (patch)
tree2f76cb08c2761d4d2c3964795cd49006a83def30 /www/py-boto3/Makefile
parent7c2703ddbbed7a873e4534b75c6c3339db666c4f (diff)
downloadports-e3b457db8a7be6504a432894a398fb17f8e0c1a7.tar.gz
ports-e3b457db8a7be6504a432894a398fb17f8e0c1a7.zip
Update to 1.9.106
- Remove LICENSE_FILE Changes: https://github.com/boto/boto3/blob/develop/CHANGELOG.rst PR: 236282 Submitted by: sunpoet (myself) Approved by: maintainer (timeout, 16 days)
Notes
Notes: svn path=/head/; revision=496507
Diffstat (limited to 'www/py-boto3/Makefile')
-rw-r--r--www/py-boto3/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/www/py-boto3/Makefile b/www/py-boto3/Makefile
index 52b699aae4e4..353b3c36d1c3 100644
--- a/www/py-boto3/Makefile
+++ b/www/py-boto3/Makefile
@@ -2,29 +2,26 @@
# $FreeBSD$
PORTNAME= boto3
-PORTVERSION= 1.4.0
+PORTVERSION= 1.9.106
CATEGORIES= www python devel
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= AWS SDK for Python
LICENSE= APACHE20
-LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.4.1:devel/py-botocore@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}botocore>=1.12.106:devel/py-botocore@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jmespath>=0.7.1:devel/py-jmespath@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.1.0:net/py-s3transfer@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}s3transfer>=0.2.0:net/py-s3transfer@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
-# Actually -2.7,3.3-3.5
+# Actually 2.6-2.7,3.3-3.7
USES= python
-USE_GITHUB= yes
USE_PYTHON= autoplist distutils
-GH_ACCOUNT= boto
-
NO_ARCH= yes
# setup.py test runs integration tests which fail