aboutsummaryrefslogtreecommitdiff
path: root/www/py-buku/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-22 07:16:51 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-22 07:16:51 +0000
commit226d5d57e13a5af3659192700e7ee2e14d75e5ea (patch)
treeb9250bb4b86d42a4d3908db04211fd005faaf57b /www/py-buku/Makefile
parent78da95113b67bb4179808e765bf69ecd19acb95a (diff)
downloadports-226d5d57e13a5af3659192700e7ee2e14d75e5ea.tar.gz
ports-226d5d57e13a5af3659192700e7ee2e14d75e5ea.zip
Powerful bookmark manager written in Python3 and SQLite3. A flexible cmdline
solution with a private, portable, merge-able database along with browser integration. buku fetches the title of a bookmarked web page and stores it along with any additional comments and tags. You can use your favourite editor to compose and update bookmarks. With multiple search options, including regex and a deep scan mode (particularly for URLs), it can find any bookmark instantly. Multiple search results can be opened in the browser at once. WWW: https://github.com/jarun/Buku
Notes
Notes: svn path=/head/; revision=454678
Diffstat (limited to 'www/py-buku/Makefile')
-rw-r--r--www/py-buku/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/www/py-buku/Makefile b/www/py-buku/Makefile
new file mode 100644
index 000000000000..2681e2ee134b
--- /dev/null
+++ b/www/py-buku/Makefile
@@ -0,0 +1,34 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= buku
+PORTVERSION= 3.5
+DISTVERSIONPREFIX= v
+CATEGORIES= www python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Powerful command-line bookmark manager
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py3-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0.1:www/py3-requests \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.21.1:net/py3-urllib3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py${PYTHON_SUFFIX}-sqlite3
+
+USES= python:3
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+GH_ACCOUNT= jarun
+GH_PROJECT= Buku
+
+PLIST_FILES= man/man1/buku.1.gz
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/buku.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>