aboutsummaryrefslogtreecommitdiff
path: root/www/py-cherrypy-old/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-11 22:18:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-11 22:18:25 +0000
commitace5a34e6a48991b6d4536dbf39739554f9bf17d (patch)
treed699c441b8f690be4a9f225b9cbba84557e4d3f7 /www/py-cherrypy-old/Makefile
parent5b2252f7492024473dbcdf63e16e3947b17de02e (diff)
downloadports-ace5a34e6a48991b6d4536dbf39739554f9bf17d.tar.gz
ports-ace5a34e6a48991b6d4536dbf39739554f9bf17d.zip
CherryPy is a pythonic, object-oriented web development framework.
CherryPy allows developers to build web applications in much the same way they would build any other object-oriented Python program. This usually results in smaller source code developed in less time. PR: ports/91686 Submitted by: Nicola Vitale <nivit@email.it>
Notes
Notes: svn path=/head/; revision=153316
Diffstat (limited to 'www/py-cherrypy-old/Makefile')
-rw-r--r--www/py-cherrypy-old/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/py-cherrypy-old/Makefile b/www/py-cherrypy-old/Makefile
new file mode 100644
index 000000000000..092045275a67
--- /dev/null
+++ b/www/py-cherrypy-old/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-cherrypy
+# Date created: 2006-01-11
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cherrypy
+PORTVERSION= 2.1.1
+CATEGORIES= www python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= CherryPy-${PORTVERSION}
+
+MAINTAINER= nivit@email.it
+COMMENT= A pythonic, object-oriented web development framework
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS= yes
+
+LN_OPTS= -sf
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+CPEXAMPLES= ${PYTHON_SITELIBDIR}/${PORTNAME}/tutorial
+
+post-install:
+ @${MV} ${CPEXAMPLES} ${EXAMPLESDIR} && \
+ ${LN} ${LN_OPTS} ${EXAMPLESDIR} ${CPEXAMPLES}
+
+.include <bsd.port.mk>