aboutsummaryrefslogtreecommitdiff
path: root/www/py-django-debug-toolbar
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-02-02 08:34:08 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-02-02 08:34:08 +0000
commitcac97723f985a019cc99bd45ceb75a63bf22479f (patch)
treed3efcd13a3f01a07cda0265dc218564662cc4999 /www/py-django-debug-toolbar
parent231e9ad4e91abe8c8333914f022fd4cceb39a6a2 (diff)
downloadports-cac97723f985a019cc99bd45ceb75a63bf22479f.tar.gz
ports-cac97723f985a019cc99bd45ceb75a63bf22479f.zip
www/py-django-debug-toolbar: Configurable panels to display debug information [NEW PORT]
The Django Debug Toolbar is a configurable set of panels that display various debug information about the current request/response and when clicked, display more details about the panel's content. WWW: https://pypi.python.org/pypi/django-debug-toolbar PR: ports/186159 Submitted by: Johannes Jost Meixner <xmj@chaot.net>
Notes
Notes: svn path=/head/; revision=342251
Diffstat (limited to 'www/py-django-debug-toolbar')
-rw-r--r--www/py-django-debug-toolbar/Makefile22
-rw-r--r--www/py-django-debug-toolbar/distinfo2
-rw-r--r--www/py-django-debug-toolbar/pkg-descr5
3 files changed, 29 insertions, 0 deletions
diff --git a/www/py-django-debug-toolbar/Makefile b/www/py-django-debug-toolbar/Makefile
new file mode 100644
index 000000000000..7f6cad593c7b
--- /dev/null
+++ b/www/py-django-debug-toolbar/Makefile
@@ -0,0 +1,22 @@
+# Created by: Johannes Meixner <xmj@chaot.net>
+# $FreeBSD$
+
+PORTNAME= django-debug-toolbar
+PORTVERSION= 1.0.1
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= xmj@chaot.net
+COMMENT= Configurable set of panels to display debug information
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django>0:${PORTSDIR}/www/py-django \
+ ${PYTHON_PKGNAMEPREFIX}sqlparse>0:${PORTSDIR}/databases/py-sqlparse
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/py-django-debug-toolbar/distinfo b/www/py-django-debug-toolbar/distinfo
new file mode 100644
index 000000000000..20134e636c8b
--- /dev/null
+++ b/www/py-django-debug-toolbar/distinfo
@@ -0,0 +1,2 @@
+SHA256 (django-debug-toolbar-1.0.1.tar.gz) = 535b1e0176a9d955601aaba3271a148368d7710569403fbc77e5299cf097c18a
+SIZE (django-debug-toolbar-1.0.1.tar.gz) = 113031
diff --git a/www/py-django-debug-toolbar/pkg-descr b/www/py-django-debug-toolbar/pkg-descr
new file mode 100644
index 000000000000..050af4d24a62
--- /dev/null
+++ b/www/py-django-debug-toolbar/pkg-descr
@@ -0,0 +1,5 @@
+The Django Debug Toolbar is a configurable set of panels that display various
+debug information about the current request/response and when clicked, display
+more details about the panel's content.
+
+WWW: https://pypi.python.org/pypi/django-debug-toolbar