aboutsummaryrefslogtreecommitdiff
path: root/www/py-flask-restplus
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-07-16 18:03:26 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-07-16 18:03:26 +0000
commitb16cc9c5c4002205c8a61fc4d5a005938cb39530 (patch)
tree6b59a2c4636eaf0dff204ec1b584bd167bec1cbf /www/py-flask-restplus
parentbb7ff5e2e1dcd44fb4728015269ca11a029c6e30 (diff)
downloadports-b16cc9c5c4002205c8a61fc4d5a005938cb39530.tar.gz
ports-b16cc9c5c4002205c8a61fc4d5a005938cb39530.zip
Extension for Flask that adds support for quickly building REST APIs.
Flask-RESTPlus encourages best practices with minimal setup. If you are familiar with Flask, Flask-RESTPlus should be easy to pick up. It provides a coherent collection of decorators and tools to describe your API and expose its documentation properly using Swagger. WWW: https://github.com/noirbizarre/flask-restplus PR: 210979 Submitted by: Andrej Ebert <andrej@ebert.su>
Notes
Notes: svn path=/head/; revision=418645
Diffstat (limited to 'www/py-flask-restplus')
-rw-r--r--www/py-flask-restplus/Makefile34
-rw-r--r--www/py-flask-restplus/distinfo3
-rw-r--r--www/py-flask-restplus/pkg-descr7
3 files changed, 44 insertions, 0 deletions
diff --git a/www/py-flask-restplus/Makefile b/www/py-flask-restplus/Makefile
new file mode 100644
index 000000000000..f9ed1d3ca9c3
--- /dev/null
+++ b/www/py-flask-restplus/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= flask-restplus
+PORTVERSION= 0.9.2
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= andrej@ebert.su
+COMMENT= Extension for Flask that adds support for quickly building REST APIs
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0.8:www/py-flask \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.3.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>0:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}aniso8601>=0.82:devel/py-aniso8601
+
+TEST_DEPENDS:= ${RUN_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}rednose>0:devel/py-rednose \
+ ${PYTHON_PKGNAMEPREFIX}blinker>0:devel/py-blinker \
+ ${PYTHON_PKGNAMEPREFIX}tzlocal>0:devel/py-tzlocal
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
+
+.include <bsd.port.mk>
diff --git a/www/py-flask-restplus/distinfo b/www/py-flask-restplus/distinfo
new file mode 100644
index 000000000000..a60bc2f2b2ff
--- /dev/null
+++ b/www/py-flask-restplus/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468167697
+SHA256 (flask-restplus-0.9.2.tar.gz) = c4313097a673ef2cffabceb44b6fdd03132ee5e7ab34d0289c37af12a3d11186
+SIZE (flask-restplus-0.9.2.tar.gz) = 868988
diff --git a/www/py-flask-restplus/pkg-descr b/www/py-flask-restplus/pkg-descr
new file mode 100644
index 000000000000..963da34f7d10
--- /dev/null
+++ b/www/py-flask-restplus/pkg-descr
@@ -0,0 +1,7 @@
+Extension for Flask that adds support for quickly building REST APIs.
+Flask-RESTPlus encourages best practices with minimal setup.
+If you are familiar with Flask, Flask-RESTPlus should be easy to pick up.
+It provides a coherent collection of decorators and tools to describe your
+API and expose its documentation properly using Swagger.
+
+WWW: https://github.com/noirbizarre/flask-restplus