aboutsummaryrefslogtreecommitdiff
path: root/www/py-gandi.cli/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-01-26 10:41:05 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-01-26 10:41:05 +0000
commit5bf9a2f4088f9de1ccd10b20a2d6b38c60a16e6f (patch)
treeb0bae23feba66024df99ae05cbfece8ec84d92c8 /www/py-gandi.cli/Makefile
parenteaa195c2d5b14acc16f38ece1323b13eeaa7a20d (diff)
downloadports-5bf9a2f4088f9de1ccd10b20a2d6b38c60a16e6f.tar.gz
ports-5bf9a2f4088f9de1ccd10b20a2d6b38c60a16e6f.zip
www/py-gandi.cli: Gandi command line interface
Use `$ gandi` to easily create and manage web resources from the command line. * `$ gandi domain` to buy and manage your domain names * `$ gandi paas` to create and deploy your web applications * `$ gandi vm` to spin up and upgrade your virtual machines * `$ gandi` to list all available commands WWW: https://github.com/Gandi/gandi.cli
Notes
Notes: svn path=/head/; revision=377931
Diffstat (limited to 'www/py-gandi.cli/Makefile')
-rw-r--r--www/py-gandi.cli/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/py-gandi.cli/Makefile b/www/py-gandi.cli/Makefile
new file mode 100644
index 000000000000..2f5a46bc56b2
--- /dev/null
+++ b/www/py-gandi.cli/Makefile
@@ -0,0 +1,39 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gandi.cli
+PORTVERSION= 0.12
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Gandi command line interface
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}click>0:${PORTSDIR}/devel/py-click \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}ipy>0:${PORTSDIR}/net-mgmt/py-ipy
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}coverage>0:${PORTSDIR}/devel/py-coverage
+
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 330
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+.endif
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.post.mk>