aboutsummaryrefslogtreecommitdiff
path: root/www/py-google-api-core/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 19:35:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 19:35:12 +0000
commitfc3e327a5ffbafb13b391220e08dd6bd9d55b818 (patch)
tree07bdeda15d51546212eb9e810eddefa1bfd8a3db /www/py-google-api-core/Makefile
parent01188789156bf206df23e9a1bec98912ae703f7e (diff)
downloadports-fc3e327a5ffbafb13b391220e08dd6bd9d55b818.tar.gz
ports-fc3e327a5ffbafb13b391220e08dd6bd9d55b818.zip
www/py-google-api-core: Update to 2.8.2
Diffstat (limited to 'www/py-google-api-core/Makefile')
-rw-r--r--www/py-google-api-core/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/py-google-api-core/Makefile b/www/py-google-api-core/Makefile
index 40096cc7762f..2c6d2e830caa 100644
--- a/www/py-google-api-core/Makefile
+++ b/www/py-google-api-core/Makefile
@@ -1,7 +1,7 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= google-api-core
-PORTVERSION= 2.8.1
+PORTVERSION= 2.8.2
CATEGORIES= www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-auth>=1.25.0<3.0:security/py-google-auth@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}googleapis-common-protos>=1.56.2<2.0:devel/py-googleapis-common-protos@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}protobuf>=3.15.0,1<4.0.0,1:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.15.0,1<5.0.0,1:devel/py-protobuf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.18.0<3.0.0:www/py-requests@${PY_FLAVOR}
USES= python:3.6+
@@ -22,13 +22,11 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= GRPC GRPCGCP
+OPTIONS_DEFINE= GRPC
OPTIONS_DEFAULT=GRPC
GRPC_DESC= gRPC support
-GRPCGCP_DESC= gRPC support for GCP
GRPC_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}grpcio>=1.33.2<2.0:devel/py-grpcio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}grpcio-status>=1.33.2<2.0:devel/py-grpcio-status@${PY_FLAVOR}
-GRPCGCP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}grpcio-gcp>=0.2.2<1.0:devel/py-grpcio-gcp@${PY_FLAVOR}
.include <bsd.port.mk>