aboutsummaryrefslogtreecommitdiff
path: root/www/py-poster
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2010-12-31 17:13:44 +0000
committerNicola Vitale <nivit@FreeBSD.org>2010-12-31 17:13:44 +0000
commitb272f7cc9d952121fdfd294bd10287e62d113240 (patch)
tree2a15d16dca5bbd9d04e7e98cee9d6ae3caa8c28f /www/py-poster
parent751f2f2ad85344351a480159b0855e1cc5335a21 (diff)
downloadports-b272f7cc9d952121fdfd294bd10287e62d113240.tar.gz
ports-b272f7cc9d952121fdfd294bd10287e62d113240.zip
The modules in the Python standard library don't provide a way to upload large
Files via HTTP without having to load the entire file into memory first. poster provides support for both streaming POST requests as well as multipart/form-data encoding of string or file parameters. WWW: http://atlee.ca/software/poster
Notes
Notes: svn path=/head/; revision=267232
Diffstat (limited to 'www/py-poster')
-rw-r--r--www/py-poster/Makefile22
-rw-r--r--www/py-poster/distinfo2
-rw-r--r--www/py-poster/pkg-descr7
-rw-r--r--www/py-poster/pkg-plist2
4 files changed, 33 insertions, 0 deletions
diff --git a/www/py-poster/Makefile b/www/py-poster/Makefile
new file mode 100644
index 000000000000..8b0aa2725a30
--- /dev/null
+++ b/www/py-poster/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-poster
+# Date created: 2010-12-30
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= poster
+PORTVERSION= 0.7.0
+#PORTREVISION= 0
+CATEGORIES= www python
+MASTER_SITES= http://atlee.ca/software/poster/dist/${PORTVERSION}/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Streaming HTTP uploads and multipart/form-data encoding
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/www/py-poster/distinfo b/www/py-poster/distinfo
new file mode 100644
index 000000000000..a8e5699e7ebe
--- /dev/null
+++ b/www/py-poster/distinfo
@@ -0,0 +1,2 @@
+SHA256 (poster-0.7.0.tar.gz) = dd85a3ed1e4c0092cb0c108095b6e83ebecdd9a16fdf0f1d51065c6adced0264
+SIZE (poster-0.7.0.tar.gz) = 12384
diff --git a/www/py-poster/pkg-descr b/www/py-poster/pkg-descr
new file mode 100644
index 000000000000..6cff45604aef
--- /dev/null
+++ b/www/py-poster/pkg-descr
@@ -0,0 +1,7 @@
+The modules in the Python standard library don't provide a way to upload large
+Files via HTTP without having to load the entire file into memory first.
+
+poster provides support for both streaming POST requests as well as
+multipart/form-data encoding of string or file parameters.
+
+WWW: http://atlee.ca/software/poster
diff --git a/www/py-poster/pkg-plist b/www/py-poster/pkg-plist
new file mode 100644
index 000000000000..7767d3e76aa1
--- /dev/null
+++ b/www/py-poster/pkg-plist
@@ -0,0 +1,2 @@
+@comment $FreeBSD$
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%