aboutsummaryrefslogtreecommitdiff
path: root/www/py-pygsheets/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:58 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-18 17:46:58 +0000
commit83f1d92e95ba14fb2e788ca1b3b5004e7132f5be (patch)
tree0853bb092b8f8a60ed8d4a95899f0f04ba69c7d9 /www/py-pygsheets/Makefile
parent8e9b9448c5eafab3bb43eef2d3b8d0d6421bfea6 (diff)
downloadports-83f1d92e95ba14fb2e788ca1b3b5004e7132f5be.tar.gz
ports-83f1d92e95ba14fb2e788ca1b3b5004e7132f5be.zip
www/py-pygsheets: Add py-pygsheets 2.0.5
A simple, intuitive library for google sheets which gets your work done. Features: - Open, create, delete and share spreadsheets using title or key - Intuitive models - spreadsheet, worksheet, cell, datarange - Control permissions of spreadsheets. - Set cell format, text format, color, write notes - Named and Protected Ranges Support - Work with range of cells easily with DataRange and Gridrange - Data validation support. checkboxes, drop-downs etc. - Conditional formatting support - get multiple ranges with get_values_batch and update wit update_values_batch WWW: https://github.com/nithinmurali/pygsheets
Diffstat (limited to 'www/py-pygsheets/Makefile')
-rw-r--r--www/py-pygsheets/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/py-pygsheets/Makefile b/www/py-pygsheets/Makefile
new file mode 100644
index 000000000000..9c7274677df0
--- /dev/null
+++ b/www/py-pygsheets/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= pygsheets
+PORTVERSION= 2.0.5
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Spreadsheets Python API v4
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-api-python-client>=1.5.5:www/py-google-api-python-client@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}google-auth-oauthlib>=0:security/py-google-auth-oauthlib@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>