aboutsummaryrefslogtreecommitdiff
path: root/www/py-recaptcha
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2009-03-20 12:14:02 +0000
committerPhilip Paeps <philip@FreeBSD.org>2009-03-20 12:14:02 +0000
commit4101083c2f590dd8ab894e32b1d166d70e0397b6 (patch)
tree755cdc8d63fb5cb5c61cadc40c4ebd20ada38ba9 /www/py-recaptcha
parent6d8ddaf8bf2967cbe7ba15b3c3d9af577ef84732 (diff)
downloadports-4101083c2f590dd8ab894e32b1d166d70e0397b6.tar.gz
ports-4101083c2f590dd8ab894e32b1d166d70e0397b6.zip
Add www/py-recaptcha: a Python plugin for reCAPTCHA and reCAPTCHA Mailhide.
Notes
Notes: svn path=/head/; revision=230477
Diffstat (limited to 'www/py-recaptcha')
-rw-r--r--www/py-recaptcha/Makefile27
-rw-r--r--www/py-recaptcha/distinfo3
-rw-r--r--www/py-recaptcha/pkg-descr8
3 files changed, 38 insertions, 0 deletions
diff --git a/www/py-recaptcha/Makefile b/www/py-recaptcha/Makefile
new file mode 100644
index 000000000000..d313a69db2a7
--- /dev/null
+++ b/www/py-recaptcha/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-recaptcha
+# Date created: 20 Mar 2009
+# Whom: Philip Paeps <philip@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= recaptcha
+PORTVERSION= 1.0.3
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_CHEESESHOP}
+MASTER_SITE_SUBDIR= source/r/recaptcha-client
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-client-${PORTVERSION}
+
+MAINTAINER= philip@FreeBSD.org
+COMMENT= A plugin for reCAPTCHA and reCAPTCHA Mailhide
+
+BUILD_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= recaptcha_client
+PYDISTUTILS_NOEGGINFO= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.include <bsd.port.mk>
diff --git a/www/py-recaptcha/distinfo b/www/py-recaptcha/distinfo
new file mode 100644
index 000000000000..22cf8266b120
--- /dev/null
+++ b/www/py-recaptcha/distinfo
@@ -0,0 +1,3 @@
+MD5 (recaptcha-client-1.0.3.tar.gz) = 5aaa88d703f1003ecc63a0ced00baad6
+SHA256 (recaptcha-client-1.0.3.tar.gz) = 5d111575d93892904906e51817a3cb7d7361d2dfd816f2490d1efe5afe5c5e3e
+SIZE (recaptcha-client-1.0.3.tar.gz) = 6623
diff --git a/www/py-recaptcha/pkg-descr b/www/py-recaptcha/pkg-descr
new file mode 100644
index 000000000000..9a6e80e185a5
--- /dev/null
+++ b/www/py-recaptcha/pkg-descr
@@ -0,0 +1,8 @@
+Provides a CAPTCHA for Python using the reCAPTCHA service. Does not require
+any imaging libraries because the CAPTCHA is served directly from reCAPTCHA.
+Also allows you to securely obfuscate emails with Mailhide. This functionality
+requires pycrypto. This library requires two types of API keys. If you'd like
+to use the CAPTCHA, you'll need a key from http://recaptcha.net/api/getkey.
+For Mailhide, you'll need a key from http://mailhide.recaptcha.net/apikey.
+
+WWW: http://cheeseshop.python.org/pypi/recaptcha-client