aboutsummaryrefslogtreecommitdiff
path: root/www/py-twistedWeb2/Makefile
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-05 14:46:07 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-05 14:46:07 +0000
commit2546e88ed33c3aa3795849146308a89f9243d92c (patch)
tree31ff7d81b21242c60b54157c3ba98da96dc18c64 /www/py-twistedWeb2/Makefile
parentfe377418bbf7dc89e36deedeb07914f4e03d3a9a (diff)
downloadports-2546e88ed33c3aa3795849146308a89f9243d92c.tar.gz
ports-2546e88ed33c3aa3795849146308a89f9243d92c.zip
Add py-twistedWeb2 - the next generation Web Server Framework built
with Twisted. PR: 84585 Submitted by: Landon Fuller <landonf@opendarwin.org> Approved by: perky (mentor)
Notes
Notes: svn path=/head/; revision=141996
Diffstat (limited to 'www/py-twistedWeb2/Makefile')
-rw-r--r--www/py-twistedWeb2/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/www/py-twistedWeb2/Makefile b/www/py-twistedWeb2/Makefile
new file mode 100644
index 000000000000..085fb764ce1f
--- /dev/null
+++ b/www/py-twistedWeb2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-twistedWeb2
+# Date created: 5 August 2005
+# Whom: Landon Fuller <landonf@opendarwin.org>
+#
+# $FreeBSD$
+
+PORTNAME= twistedWeb2
+PORTVERSION= 0.1
+CATEGORIES= www devel python
+MASTER_SITES= http://twistedmatrix.com/downloads/Web2/ \
+ http://tmrc.mit.edu/mirror/twisted/Web2/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= TwistedWeb2-${PORTVERSION}
+
+MAINTAINER= landonf@opendarwin.org
+COMMENT= The next generation Web Server Framework built with Twisted
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/twisted:${PORTSDIR}/devel/py-twistedCore
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/TwistedWeb2-${PORTVERSION}
+
+USE_BZIP2= yes
+USE_PYTHON= 2.2+
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>