aboutsummaryrefslogtreecommitdiff
path: root/www/qt4-webkit/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-01-09 14:07:28 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-01-09 14:07:28 +0000
commit4fa79bc5b5dde88fe7a5ffcd24e929c723838941 (patch)
treeea00b8c8bea9bd9383ce8ffac0e01457cd711c82 /www/qt4-webkit/Makefile
parent4e529dbde1a63f16c1ff673c0c24d5823f570029 (diff)
downloadports-4fa79bc5b5dde88fe7a5ffcd24e929c723838941.tar.gz
ports-4fa79bc5b5dde88fe7a5ffcd24e929c723838941.zip
- Add dependency on devel/binutils' ld(1) to fix build on PowerPC.
PR: 173042 Submitted by: Justin Hibbits <jrh29@po.cwru.edu>
Notes
Notes: svn path=/head/; revision=310146
Diffstat (limited to 'www/qt4-webkit/Makefile')
-rw-r--r--www/qt4-webkit/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/www/qt4-webkit/Makefile b/www/qt4-webkit/Makefile
index 4ec7ead9f8b4..9d707b8018dc 100644
--- a/www/qt4-webkit/Makefile
+++ b/www/qt4-webkit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qt4-webkit
-# Date created: Mon May 12 17:18:19 CEST 2008
-# Whom: danny@ricin.com
-#
+# Created by: danny@ricin.com
# $FreeBSD$
-#
PORTNAME= webkit
DISTVERSION= ${QT4_VERSION}
@@ -48,6 +44,14 @@ CONFIGURE_ARGS+= -I../../../../include/Qt -I../../../../include
EXTRA_PATCHES= ${.CURDIR}/../../devel/qt4/files/patch-configure
+.include <bsd.port.pre.mk>
+
+# Base ld(1) segfaults on PowerPC:
+# http://bugs.freebsd.org/173042
+.if ${ARCH} == "powerpc"
+BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:${PORTSDIR}/devel/binutils
+.endif
+
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
${LN} -sf ${LOCALBASE}/bin/qmake-qt4 ${WRKSRC}/bin/qmake
@@ -77,4 +81,4 @@ post-configure:
${WRKSRC}/lib/pkgconfig/QtWebKit.pc \
${WRKSRC}/lib/libQtWebKit.la
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>