aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-06 04:26:17 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-03-06 04:33:32 +0000
commit8067206f03a28c8eb926d07550d94220d7aacfbd (patch)
tree530cc45a182768dd7619e3aed11c104d94b2e461 /www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
parentd69b20995dec38f96ef28522bc6156a7d5b80fff (diff)
downloadports-8067206f03a28c8eb926d07550d94220d7aacfbd.tar.gz
ports-8067206f03a28c8eb926d07550d94220d7aacfbd.zip
www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to version 96.0.4664.110 and patches were taken from of www/chromium 87.0.4280.141 (391acded85d8). * Prune some unneeded patches (mostly from the headless and unittest areas) and try to align the unbundling of dependencies similar to qt6-webengine for consistency. * Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles has changed since Qt 5.15.3. Tested by: tcberner Differential Revision: https://reviews.freebsd.org/D38165
Diffstat (limited to 'www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn')
-rw-r--r--www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn43
1 files changed, 26 insertions, 17 deletions
diff --git a/www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn b/www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
index d0328ec408a0..be4c4ae2a7fb 100644
--- a/www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
+++ b/www/qt5-webengine/files/patch-src_3rdparty_chromium_BUILD.gn
@@ -1,15 +1,15 @@
---- src/3rdparty/chromium/BUILD.gn.orig 2020-11-07 01:22:36 UTC
+--- src/3rdparty/chromium/BUILD.gn.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/BUILD.gn
-@@ -419,7 +419,7 @@ group("gn_all") {
+@@ -423,7 +423,7 @@ group("gn_all") {
]
}
-- if (is_linux || is_android) {
-+ if ((is_linux && !is_bsd) || is_android) {
+- if (is_linux || is_chromeos || is_android) {
++ if ((is_linux && !is_bsd) || is_chromeos || is_android) {
deps += [
"//third_party/breakpad:breakpad_unittests",
"//third_party/breakpad:core-2-minidump",
-@@ -460,8 +460,6 @@ group("gn_all") {
+@@ -464,8 +464,6 @@ group("gn_all") {
"//net:disk_cache_memory_test",
"//net:quic_client",
"//net:quic_server",
@@ -18,7 +18,7 @@
"//testing:empty_main",
]
-@@ -516,10 +514,6 @@ group("gn_all") {
+@@ -520,10 +518,6 @@ group("gn_all") {
"//chrome/test:load_library_perf_tests",
"//chrome/test:sync_performance_tests",
"//chrome/test/chromedriver:chromedriver",
@@ -29,7 +29,7 @@
"//media/cast:generate_barcode_video",
"//media/cast:generate_timecode_audio",
"//net:crash_cache",
-@@ -592,10 +586,6 @@ group("gn_all") {
+@@ -595,10 +589,6 @@ group("gn_all") {
"//mojo:mojo_perftests",
"//services/service_manager/public/cpp",
"//testing/gmock:gmock_main",
@@ -40,7 +40,7 @@
]
if (!is_android) {
-@@ -669,7 +659,7 @@ group("gn_all") {
+@@ -676,7 +666,7 @@ group("gn_all") {
host_os == "win" && !use_qt) {
deps += [ "//chrome/test/mini_installer:mini_installer_tests" ]
}
@@ -49,16 +49,25 @@
deps += [ "//third_party/breakpad:symupload($host_toolchain)" ]
}
-@@ -802,7 +792,6 @@ group("gn_all") {
+@@ -691,7 +681,7 @@ group("gn_all") {
+ }
+ }
+
+- if (is_mac || is_win || is_android || (is_linux && !is_chromeos)) {
++ if (is_mac || is_win || is_android || (is_linux && !is_chromeos && !is_bsd)) {
+ deps += [
+ "//third_party/crashpad/crashpad:crashpad_tests",
+ "//third_party/crashpad/crashpad/handler:crashpad_handler",
+@@ -810,7 +800,6 @@ group("gn_all") {
"//chrome/browser/vr:vr_common_perftests",
"//chrome/browser/vr:vr_common_unittests",
"//chrome/browser/vr:vr_pixeltests",
- "//tools/perf/contrib/vr_benchmarks:vr_perf_tests",
]
- if (is_desktop_linux && use_ozone) {
- deps += [ "//chrome/browser/vr/testapp:vr_testapp" ]
-@@ -1085,7 +1074,7 @@ if (!is_ios && !use_qt) {
- ]
+ if (is_android) {
+ deps += [ "//chrome/browser/android/vr:vr_android_unittests" ]
+@@ -1103,7 +1092,7 @@ if (!is_ios && !use_qt) {
+ data_deps += [ "//content/web_test:web_test_common_mojom_js_data_deps" ]
}
- if (!is_win && !is_android) {
@@ -66,16 +75,16 @@
data_deps +=
[ "//third_party/breakpad:minidump_stackwalk($host_toolchain)" ]
}
-@@ -1094,7 +1083,7 @@ if (!is_ios && !use_qt) {
+@@ -1112,7 +1101,7 @@ if (!is_ios && !use_qt) {
data_deps += [ "//third_party/breakpad:dump_syms($host_toolchain)" ]
}
-- if (is_linux) {
-+ if (is_linux && !is_bsd) {
+- if (is_linux || is_chromeos) {
++ if ((is_linux && !is_bsd) || is_chromeos) {
data_deps += [ "//third_party/breakpad:dump_syms($host_toolchain)" ]
}
-@@ -1286,9 +1275,6 @@ group("chromium_builder_perf") {
+@@ -1308,9 +1297,6 @@ group("chromium_builder_perf") {
if (is_win) {
data_deps += [ "//chrome/installer/mini_installer:mini_installer" ]