aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser...
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-03-27 22:34:04 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-03-27 22:34:04 +0000
commit21980ea6a92954676eedd7334c7a57013969f895 (patch)
tree6a3627cb17e42352db5107b5a439b294365a3c37 /www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc
parentb4ace54c0e0dfc6bf7eb4f8b2bf196dd40848daf (diff)
downloadports-21980ea6a92954676eedd7334c7a57013969f895.tar.gz
ports-21980ea6a92954676eedd7334c7a57013969f895.zip
www/qt5-webengine: Update to 5.12.1
It was again a long journey to bring the port in sync with the other Qt5 ports. It runs now under the hood with Chromium 69.0.3497.128 and applied security fixes up to version 71.0.3578.94. Also the approach with the handling of the BUILD.gn files has changed. With the previous version of www/qt5-webengine (and www/chromium up to r449991) the boolean variables "is_bsd" and "is_posix" were set to true in BUILDCONFIG when FreeBSD was detected as operating system during the build process. Now the boolean variable "is_linux" is set to true as well and this reduces some patching of BUILD.gn files. It makes it (hopefully) also somewhat easier to exclude Linux-only features from future www/qt5-webengine versions. The .debug entries in the pkg-plist are prefixed with @comment each as a temporary workaround because building with "separate_debug_info" fails to build QtWebEngineProcess at the moment. (see also: QTBUG-74312) Many kudos must go to the FreeBSD Chromium team for their ongoing efforts to keep the browser in a good shape. I was able to use a decent amount of patches from there which sped up the whole process. At last but not least: Many thanks must also go to rakuco@ for finding the last pieces to make www/qt5-webengine more usable and tcberner@ for the moral support during the whole time. Changelogs: https://code.qt.io/cgit/qt/qtwebengine.git/tree/dist/changes-5.12.0 https://code.qt.io/cgit/qt/qtwebengine.git/tree/dist/changes-5.12.1 PR: 234470 [1] (related), 235075 [2] Reported by: Michael Danilov [2], aeuii@posteo.de [1] Reviewed by: rakuco, tcberner (mentor) Approved by: rakuco, tcberner (mentor), kde (maintainer) Differential Revision: https://reviews.freebsd.org/D18757
Notes
Notes: svn path=/head/; revision=496989
Diffstat (limited to 'www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc')
-rw-r--r--www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc11
1 files changed, 11 insertions, 0 deletions
diff --git a/www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc b/www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc
new file mode 100644
index 000000000000..15b66ed1b8b7
--- /dev/null
+++ b/www/qt5-webengine/files/patch-src_3rdparty_chromium_components_network__session__configurator_browser_network__session__configurator.cc
@@ -0,0 +1,11 @@
+--- src/3rdparty/chromium/components/network_session_configurator/browser/network_session_configurator.cc.orig 2018-11-13 18:25:11 UTC
++++ src/3rdparty/chromium/components/network_session_configurator/browser/network_session_configurator.cc
+@@ -591,7 +591,7 @@ net::URLRequestContextBuilder::HttpCacheParams::Type C
+ }
+ #endif // #if !defined(OS_ANDROID)
+
+-#if defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS)
++#if defined(OS_ANDROID) || defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_BSD)
+ return net::URLRequestContextBuilder::HttpCacheParams::DISK_SIMPLE;
+ #else
+ return net::URLRequestContextBuilder::HttpCacheParams::DISK_BLOCKFILE;