aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-06 04:26:17 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-03-06 04:33:32 +0000
commit8067206f03a28c8eb926d07550d94220d7aacfbd (patch)
tree530cc45a182768dd7619e3aed11c104d94b2e461 /www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc
parentd69b20995dec38f96ef28522bc6156a7d5b80fff (diff)
downloadports-8067206f03a28c8eb926d07550d94220d7aacfbd.tar.gz
ports-8067206f03a28c8eb926d07550d94220d7aacfbd.zip
www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to version 96.0.4664.110 and patches were taken from of www/chromium 87.0.4280.141 (391acded85d8). * Prune some unneeded patches (mostly from the headless and unittest areas) and try to align the unbundling of dependencies similar to qt6-webengine for consistency. * Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles has changed since Qt 5.15.3. Tested by: tcberner Differential Revision: https://reviews.freebsd.org/D38165
Diffstat (limited to 'www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc')
-rw-r--r--www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc12
1 files changed, 6 insertions, 6 deletions
diff --git a/www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc b/www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc
index c27b7e8e88f0..574d1cc48707 100644
--- a/www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc
+++ b/www/qt5-webengine/files/patch-src_3rdparty_chromium_content_public_common_content__constants.cc
@@ -1,11 +1,11 @@
---- src/3rdparty/chromium/content/public/common/content_constants.cc.orig 2020-11-07 01:22:36 UTC
+--- src/3rdparty/chromium/content/public/common/content_constants.cc.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/content/public/common/content_constants.cc
-@@ -46,7 +46,7 @@ const int kDefaultDetachableCancelDelayMs = 30000;
- const char kCorsExemptPurposeHeaderName[] = "Purpose";
- const char kCorsExemptRequestedWithHeaderName[] = "X-Requested-With";
+@@ -56,7 +56,7 @@ std::string GetCorsExemptRequestedWithHeaderName() {
+ return base::JoinString(pieces, "-");
+ }
--#if defined(OS_LINUX)
-+#if defined(OS_LINUX) || defined(OS_BSD)
+-#if defined(OS_LINUX) || defined(OS_CHROMEOS)
++#if defined(OS_LINUX) || defined(OS_CHROMEOS) || defined(OS_BSD)
const int kLowestRendererOomScore = 300;
const int kHighestRendererOomScore = 1000;