aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo...
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2023-03-06 04:26:17 +0000
committerKai Knoblich <kai@FreeBSD.org>2023-03-06 04:33:32 +0000
commit8067206f03a28c8eb926d07550d94220d7aacfbd (patch)
tree530cc45a182768dd7619e3aed11c104d94b2e461 /www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp
parentd69b20995dec38f96ef28522bc6156a7d5b80fff (diff)
downloadports-8067206f03a28c8eb926d07550d94220d7aacfbd.tar.gz
ports-8067206f03a28c8eb926d07550d94220d7aacfbd.zip
www/qt5-webengine: Update to 5.15.8
* Under the hood runs Chromium 87.0.4280.144 with security fixes up to version 96.0.4664.110 and patches were taken from of www/chromium 87.0.4280.141 (391acded85d8). * Prune some unneeded patches (mostly from the headless and unittest areas) and try to align the unbundling of dependencies similar to qt6-webengine for consistency. * Adjust Mk/Uses/qt-dist.mk accordingly as the naming of the distfiles has changed since Qt 5.15.3. Tested by: tcberner Differential Revision: https://reviews.freebsd.org/D38165
Diffstat (limited to 'www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp')
-rw-r--r--www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp7
1 files changed, 3 insertions, 4 deletions
diff --git a/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp b/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp
index badcf937c4a8..544f9bb4fa2d 100644
--- a/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp
+++ b/www/qt5-webengine/files/patch-src_3rdparty_chromium_third__party_angle_src_gpu__info__util_SystemInfo__x11.cpp
@@ -1,4 +1,4 @@
---- src/3rdparty/chromium/third_party/angle/src/gpu_info_util/SystemInfo_x11.cpp.orig 2018-11-13 18:25:11 UTC
+--- src/3rdparty/chromium/third_party/angle/src/gpu_info_util/SystemInfo_x11.cpp.orig 2021-12-15 16:12:54 UTC
+++ src/3rdparty/chromium/third_party/angle/src/gpu_info_util/SystemInfo_x11.cpp
@@ -8,6 +8,8 @@
@@ -9,8 +9,8 @@
#include <X11/Xlib.h>
#include "common/debug.h"
-@@ -18,8 +20,44 @@
- #error SystemInfo_x11.cpp compiled without GPU_INFO_USE_X11
+@@ -18,8 +20,43 @@
+ # error SystemInfo_x11.cpp compiled without GPU_INFO_USE_X11
#endif
+#define GLX_RENDERER_VENDOR_ID_MESA 0x8183
@@ -50,7 +50,6 @@
+
+ return true;
+}
-+
bool GetNvidiaDriverVersionWithXNVCtrl(std::string *version)
{