aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webkit/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-27 14:06:05 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2017-08-27 14:06:05 +0000
commite9a6c165fa893d2423d2acabfd7489f6ed915d77 (patch)
tree41b2e60e30a7445c8378fd53580b10d9d8c30a06 /www/qt5-webkit/Makefile
parent994b3ce426eddc0a8e2f54638ec2ad5df362befd (diff)
downloadports-e9a6c165fa893d2423d2acabfd7489f6ed915d77.tar.gz
ports-e9a6c165fa893d2423d2acabfd7489f6ed915d77.zip
Ensure qconfig-modules.h does not include qconfig-webkit.h
r448361 updated Qt WebKit and dropped QT_DIST and QT_DEFINES, which led to existing installations being upgraded to remove qconfig-webkit.h while not removing the corresponding #include <QtCore/modules/qconfig-webkit.h> from qconfig-modules.h. Consequently, any build that uses existing Qt5 ports (i.e. building a port locally, or any project using Qt5) fails with errors like: /usr/local/include/qt5/QtCore/qconfig-modules.h:8:10: fatal error: 'QtCore/modules/qconfig-webkit.h' file not found Add a pkg-install that takes care of removing any offending lines from qconfig-modules.h. PR: 221828 Reviewed by: tcberner, Adriaan de Groot <groot@kde.org>
Notes
Notes: svn path=/head/; revision=448821
Diffstat (limited to 'www/qt5-webkit/Makefile')
-rw-r--r--www/qt5-webkit/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index 8db128fbea4d..60d9e149f12e 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -2,6 +2,7 @@
PORTNAME= webkit
DISTVERSION= 5.212.0-alpha2
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= https://github.com/annulen/${PORTNAME}/releases/download/${DISTNAME}/
PKGNAMEPREFIX= qt5-
@@ -46,4 +47,7 @@ CXXFLAGS+= -DNDEBUG
PLIST_SUB= FULLVER="${PORTVERSION:R}"
+SUB_FILES= pkg-install
+SUB_LIST= QT_INCDIR="${QT_INCDIR}"
+
.include <bsd.port.mk>