aboutsummaryrefslogtreecommitdiff
path: root/www/qt5-webkit
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 18:14:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-10-27 18:14:44 +0000
commitb1378e64a3064d1825c06f78e98f7599e895f773 (patch)
treedf1ffea3aa7893d615e6c57c840c0adf07d9eb94 /www/qt5-webkit
parentfe6ef66ee0e96807e8d54ffdfcd52f613dbab58f (diff)
downloadports-b1378e64a3064d1825c06f78e98f7599e895f773.tar.gz
ports-b1378e64a3064d1825c06f78e98f7599e895f773.zip
www/qt5-webkit: fix build with powerpc64
PR: 232257 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=483164
Diffstat (limited to 'www/qt5-webkit')
-rw-r--r--www/qt5-webkit/Makefile5
-rw-r--r--www/qt5-webkit/files/patch-CMakeLists.txt11
-rw-r--r--www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h23
3 files changed, 34 insertions, 5 deletions
diff --git a/www/qt5-webkit/Makefile b/www/qt5-webkit/Makefile
index b5a8efed85b1..f476206f4b69 100644
--- a/www/qt5-webkit/Makefile
+++ b/www/qt5-webkit/Makefile
@@ -19,8 +19,9 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png \
libwebp.so:graphics/webp
-USES= bison cmake:outsource gperf jpeg pathfix perl5 pkgconfig \
- python:2.7,build qt:5 sqlite:3 tar:xz
+USES= bison cmake:outsource compiler:c++11-lang gperf jpeg \
+ pathfix perl5 pkgconfig python:2.7,build qt:5 sqlite:3 \
+ tar:xz
USE_GNOME= glib20 libxml2 libxslt
USE_GSTREAMER1= core
USE_QT= core gui location network opengl printsupport \
diff --git a/www/qt5-webkit/files/patch-CMakeLists.txt b/www/qt5-webkit/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..3ef158caa59b
--- /dev/null
+++ b/www/qt5-webkit/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-10-14 18:01:08 UTC
++++ CMakeLists.txt
+@@ -73,6 +73,8 @@ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "ppc"
+ set(WTF_CPU_PPC 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64")
+ set(WTF_CPU_PPC64 1)
++elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "powerpc64")
++ set(WTF_CPU_PPC64 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "ppc64le")
+ set(WTF_CPU_PPC64LE 1)
+ elseif (LOWERCASE_CMAKE_SYSTEM_PROCESSOR MATCHES "parisc*")
diff --git a/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h b/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h
index 823edc05fb43..a24892207891 100644
--- a/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h
+++ b/www/qt5-webkit/files/patch-Source_WTF_wtf_Platform.h
@@ -6,7 +6,24 @@ Add proper architecture name:
--- Source/WTF/wtf/Platform.h.orig 2017-06-04 20:16:06 UTC
+++ Source/WTF/wtf/Platform.h
-@@ -226,6 +226,7 @@
+@@ -105,11 +105,15 @@
+
+ /* CPU(PPC64) - PowerPC 64-bit Big Endian */
+ #if ( defined(__ppc64__) \
+- || defined(__PPC64__)) \
++ || defined(__PPC64__) \
++ || defined(__powerpc64__)) \
+ && defined(__BYTE_ORDER__) \
+ && (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__)
+ #define WTF_CPU_PPC64 1
+ #define WTF_CPU_BIG_ENDIAN 1
++#define ENABLE_ASSEMBLER 0
++#define ENABLE_JIT 0
++#define ENABLE_SAMPLING_PROFILER 0
+ #endif
+
+ /* CPU(PPC64) - PowerPC 64-bit Little Endian */
+@@ -226,6 +230,7 @@
#elif defined(__ARM_ARCH_6__) \
|| defined(__ARM_ARCH_6J__) \
|| defined(__ARM_ARCH_6K__) \
@@ -14,8 +31,8 @@ Add proper architecture name:
|| defined(__ARM_ARCH_6Z__) \
|| defined(__ARM_ARCH_6ZK__) \
|| defined(__ARM_ARCH_6T2__) \
-@@ -272,6 +273,7 @@
-
+@@ -272,6 +277,7 @@
+
#elif defined(__ARM_ARCH_6J__) \
|| defined(__ARM_ARCH_6K__) \
+ || defined(__ARM_ARCH_6KZ__) \