aboutsummaryrefslogtreecommitdiff
path: root/www/riot-web/Makefile
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-10-31 16:49:35 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-10-31 16:49:35 +0000
commit5d6796c0792169b1f8495dda07366d93c4c80984 (patch)
tree0ce7def9257e1f4c8862303ebac54934a2ee2ed4 /www/riot-web/Makefile
parent0c849d4f569e638dd0bcd4bba60d915071c36cdb (diff)
downloadports-5d6796c0792169b1f8495dda07366d93c4c80984.tar.gz
ports-5d6796c0792169b1f8495dda07366d93c4c80984.zip
New port: www/riot-web: Glossy Matrix collaboration client for the web
Riot (formerly known as Vector) is a Matrix web client built using the Matrix React SDK. Riot is officially supported on the web in modern versions of Chrome, Firefox, and Safari. Other browsers may work, however official support is not provided. For accessing Riot on an Android or iOS device, check out riot-android and riot-ios - riot-web does not support mobile devices. WWW: https://github.com/vector-im/riot-web PR: 240972 Submitted by: Alexander Sieg <alex@xanderio.de>
Notes
Notes: svn path=/head/; revision=516177
Diffstat (limited to 'www/riot-web/Makefile')
-rw-r--r--www/riot-web/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/www/riot-web/Makefile b/www/riot-web/Makefile
new file mode 100644
index 000000000000..8806cf2dead7
--- /dev/null
+++ b/www/riot-web/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= riot
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.0
+CATEGORIES= www
+MASTER_SITES= https://github.com/vector-im/riot-web/releases/download/${DISTVERSIONFULL}/
+PKGNAMESUFFIX= -web
+
+MAINTAINER= alex@xanderio.de
+COMMENT= Glossy Matrix collaboration client for the web
+
+LICENSE= APACHE20
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}
+
+.include <bsd.port.mk>